Forum OpenACS Q&A: Having troubles with 3.2.5 and pg7.0

Hi all...

I've been trying to load 3.2.5 and am having troubles. Without going
into deep detail I just wanted to ask if it could be related to pg7.0
instead of pg 7.1. I saw another thread talking about troubles with
7.1.1, so that's what lead me in this direction.



Posted by Don Baccus on
It should install fine with either PG 7.0.3 or PG 7.1.0.  It is only PG 7.1.1 that dies AFAIK, and the symptom you posted earlier was exactly the symptom one expects from the bug that crept into that release.
Posted by Troy Bradley on
I downloaded a bunch of RPMS as mentioned on Jonathon's (?) site,
which says they will work on a Linux box running RH 7.1 _without_
postgresql or aolserver. (The RPMs include both.)

I then noticed that my RH 7.1 box had Pg 7.0 installed, so I
uninstalled it and tried my best to remove anything that relied on
any of it (some devel stuff that I may someday learn to use, etc.)

So now I am trying to install OpenACS 3.2.5, AOLserver (latest), and
Pg 7.1 from the RPMs I downloaded earlier.

My problem is dependencies. I have a libxml RPM file for AOLserver,
but it needs and A search for
these on google turns up readline and glibc 2.2.3 as a possible
solution from linuxppc. I have added these to the list of RPMs, but
now get a much longer list of conflicts and more instances of and being needed by the various

I've read the documentation, but seem to be missing something. Could
have something to do with the fact that it is now 1am, but I'd
appreciate pointers from anyone, as you all probably have more
experience than me.


Posted by Jonathan Marsden on
Troy, libxml binary RPMs compiled for RH 7.1 do not seem to exist, even at the official home of libxml.

Solution: obtain the libxml2 source RPM and rebuild it on your RH 7.1 machine, then install the newly created libxml2 binary RPM.

I'll probably do this and stick a libxml2 binary RPM for RH 7.1 on my site any day now ... but until then, grabbing the source RPM and doing

rpm --rebuild libxml2-2.3.8-1.src.rpm

should work.

I have not tried these RPMs with any version of PG except PG 7.1 so far.

Posted by Troy Bradley on
Thanks Jonathon, I'll try that and post my results here.
Posted by Troy Bradley on
I downloaded the latest source rpm from xmlsoft,
libxml2-2.3.9-1.src.rpm, then did the rpm --rebuild as instructed.

Then in the same directory, I tried "rpm -Uvh *rpm" as per the
original instructions. Only now I get

" is needed by aolserver-3.2-4+as12+nsxml"

Any ideas?

Thanks again Jonathan, for the RPMs and the follow-up on this
thread. I'll try not to typo your name again.

Posted by Don Baccus on
You don't need nsxml for OpenACS 3.2.5, just OpenACS 4 (our current project).  So just scratch that from the initialization file.

Did that creep into the RPMs by accident?

Posted by Vadim Nasardinov on

Troy Bradley wrote:

Then in the same directory, I tried "rpm -Uvh *rpm" as per the original instructions. Only now I get

" is needed by aolserver-3.2-4+as12+nsxml"


rpm -Uvh --force --nodeps *rpm
Posted by Jonathan Marsden on
nsxml is there so that the aolserver RPMs are ready for OpenACS4.

Troy, I suspect you rebuilt libxml2 but did not install the resulting binary RPM at all? Look for it in /usr/src/redhat/RPMS/i386/ (unless you have been playing games with the rpm config files on your machine!) and move it to the directory with all the other OpenACS-related RPMs in it before you do the

rpm -Uvh *rpm
Posted by Troy Bradley on
Jonathan, You suspect correctly. Being a newbie to Linux, AOLserver, and programming in general, I have not been playing games with too many settings at all ;)

I did the --force --nodeps and that seems to have installed everything, but I haven't had time to start AOLserver and PG to make sure that everything is operational.

Should I upgrade my libxml with my newly built rpm now or wait a couple of months when I am sure that Don, Ben and crew will deliver OpenACS 4 on time, (unlike a certain $oftware giant (M$FT)) ???

Thanks again to everybody for the help with this!

11: Up and Running! (response to 1)
Posted by Troy Bradley on
Thanks to all who helped me on this thread, I now have an OpenACS
login page at "localhost:8000".

There is still a lot of "magic" that I'd like to figure out, like:
"Where are all the files?" I don't see a /web on my machine and
"locate .tcl" just turns up files from applications I've installed,
not web pages - same for "locate .adp"

I should have some time this weekend to look into this.

Thanks again, everybody, for helping out.

Posted by max sekar on
Hi, I installed OpenACS 3.2.5 on Mandrake 7.2.
  • Custom install of Mandrake 7.2 without PostgreSQL or Apache.
  • Install all RPMs of PostgreSQL 7.1 from site by downloading all RPMs and rpm -ivh p*.rpm from that directory.
  • Install libxml2 from using rpm -ivh --nodeps --force libxml2-2.3.7-1.i386.rpm.
  • Download the AOLServer and the database driver from and Install with rpm -ivh aolserver*.rpm.
  • Get OpenACS from and install with rpm -ivh openacs*.rpm.
  • Browse to http://localhost:8000/
      That's about it for installation. A big thanks to Jonathan Marsden for making it this easy and painless!!
Posted by Jonathan Marsden on

(1) I'd update your libxml2 with the newly built RPM.

(2) The file location info is listed in the README-rpm.txt file,
installed at /usr/doc/openacs-3.2.5/README-rpm.txt on your machine.

Another way to find out where an RPM installs files is to list them
with the command

  rpm -ql openacs