Forum OpenACS Development: I've tried openacs4 with aolserver3.4 and it works !!!!

I've downloaded the recent released aolserver 3.4 and tried to run openacs4 and it seems to work fine.

Someone else have tried ?

There is any possible problems that someone else can see on it ?

Well it works with an already installed openacs4, when I tried to reisntall using aolserver3.4 the installation proceed OK but when restart it fails because there isn't "ns_charset" in this release.
Hmmm...that's probably because AOLserver 3.4 has its own set of solutions to the charset problem which differs from AOLserver 3.2+aD12.

Someone should investigate, but I'd put this at a low priority.  AOLserver 3.2+ aD12 is known to be stable and the major memory leak issue goes away if you set minthreads=maxthreads, which AOLserver recommends one do anyway (at least that's what they do at and

RE: the minthreads=maxthreads note (which I'd forgotten about...). Is there anyplace in particular I need to put that in the tcl init file (ns/threads, or something...?)


The AOLserver3.4 issue is kind of important for me, because I would like to
integrate the patches I made for ACS 4.x for internationalization into
OpenACS4, but they will only work with the ArsDigita 3.2+ad12 aolserver patches.

So, if I try to add these patches into the new OpenACS 4 core, then
OpenACS 4 will not run with the AOLserver 3.4.

So ... I am not sure which way to go on that. I can keep the
i18n patches as a separate patch file, and then people can
pick and choose, but it would be better if OpenACS 4 shipped "out of the box" supporting multiple charsets happily.