Forum OpenACS Development: Re: BSD installer: FreeBSD port

Posted by Tyge Cawthon on
Got some good news about the port. I have just tried it from a fresh install of FreeBSD 5.3. Everthing worked correctly up to the first initial reboot with OpenACS loaded.

After the installation of OpenACS, the installer is requested to enter in information such as name, password, etc. After I did that, I changed the port information to reflect port 433 and 80 in the files:


When I reboot I see no new log files here:
just the org. ones from the install.

There was only one error message in the org log:
[22/Dec/2004:17:52:16][13870.137931776][-shutdown-] Notice: nslog: closing '/var/lib/aolserver/service0/log/service0.log'
[22/Dec/2004:17:52:17][13870.134557696][-main-] Error: pidfile: failed to remove '/usr/local/aolserver/log/nspid.service0': 'No such file or directory'
[22/Dec/2004:17:52:17][13870.134557696][-main-] Notice: nsmain: AOLserver/4.0.9 exiting

I have since changed all files back to the org install. I am still having problems reaching the server using a browser. I can ping it using the IP or server name

Here is what is running.

ps -auxww | grep aol
service0 1666 0.0 0.7 1472 888 p0 S+ 10:48PM 0:00.02 grep aol

ps -auxwww | grep service
root 1634 0.0 1.0 1600 1260 p0 I 10:42PM 0:00.07 su - service0
service0 1635 0.0 1.0 1640 1176 p0 S 10:42PM 0:00.05 -su (sh)
service0 1703 0.0 0.7 1412 904 p0 R+ 10:56PM 0:00.02 ps -auxwww
service0 1704 0.0 0.7 1476 892 p0 S+ 10:56PM 0:00.02 grep service
root 433 0.0 0.5 1236 664 con- S 7:42PM 0:01.59 /usr/local/bin/svscan /service/
root 438 0.0 0.5 1188 600 con- I 7:42PM 0:00.84 supervise service0

Thinking there was a problem with AOLserver I executed this command as service0:
/usr/local/aolserver/bin/nsd-postgres -t /var/lib/aolserver/service0/etc/config.tcl
and got is reported back.
/libexec/ Shared object "" not found, required by "nsd"

Any suggestions?

Posted by xx xx on

Great to hear it worked at first. Too bad it broke.

1. Correct .profile as described in my response to T.K. above (I'll have to update the port)

2. I didn't include openssl yet. To install type:
# to search
cd /usr/ports
make search name=openssl
# or direct
cd /usr/ports/security/openssl
make install
# and good luck :)

3. BTW, don't edit daemontools/run in place always copy to, then edit file and copy it back to run. Try (if you have rebooted at least once):
# bring down
svc -d /service/service0
# start daemontools
svc -u /service/service0

4. find out if there is a permissioning problem.
ls -al /usr/local/aolserver
chown -R root:wheel /usr/local/aolserver

ls -al /var/lib/aolserver/service0/etc/
chmod -R 755 /var/lib/aolserver/service0/etc/daemontools
chmod -R 755 /service/service0

5. I'm not sure about the shared object thing. There are several options.

# A. This will probably help you out one time. I would think it should work after a reboot
# but actually it doesn't keep the information.....
/sbin/ldconfig -m /usr/local/aolserver/lib

# B. Then there is libman.conf which you probably can create. But it isn't on my system.
man libman.conf

# C. What does work is changing rc.conf
# Default values are set in /etc/defaults/rc.conf but you can override them in /etc/rc.conf
ee /etc/rc.conf
   # add
   ldconfig_paths="/usr/lib/compat /usr/X11R6/lib /usr/local/lib /usr/local/aolserver/lib"
# reboot
shutdown -r now

# D. The best option may be to add the lib directory to LD_LIBRARY_PATHS
# in .profile of your users (if it works for you too).
ee ~/.profile
   export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/pgsql/lib:/usr/local/aolserver/lib

# E. You can even link them statically with "ln -s", once you have discovered what is wrong:
/usr/bin/ldd /usr/local/aolserver/bin/nsd

What is is right and what is wrong? The easiest seems to be the .profile option. Tell me if that works for you. Good luck.

Posted by T.K. kang on
Thanks for the detail instruction. Trying to digest what I have to do as I am not really a very technical person. I am stuck with FreeBSD 4.10 as I could not get 5.3 running on my computer - whatever reason. All things seems to install O.K. but aolserver not loaded automatically on reboot.

Perhaps I should wait for whatever to be updated in your port to give it a new try. Appreciate if you could give it a go with the 4.10

Thanks and I really appreciate the assistance here. Too bad I am less technical compared to Brian who is now a happy person!!

A Merry Christmas to you.