Forum OpenACS Q&A: NN/IE page loading errors

Posted by James Cutler on

I've recently installed OpenACS 3.2.5, AOLserver 3.4, and PostgreSQL
7.1.3 on a Redhat 7.0 machine.  The installation process seems to
have gone well but I cannot access the pages successfully.

I can access them fine using Lynx and older versions of Netscape
(4.71 on a Linux system).  But I cannot access the pages from Windows
2000 with Netscape 6 and Internet Explore 5.50.  NN and IE just make
repeated requests to the server.  Both have cookies enabled.  Opera 5
on my Windows machines returns a redirection page redirecting to the
page I asked for.

Running aolserver on the sample config file produces correct
operation so it seems to be an OpenACS issue.

I'm perplexed at the different responses of different browsers.  Does
anyone know what I've misconfigured?  Has anyone seen this before?


Posted by David Walker on
Here's my theory.

The default settings of OpenACS have a primary server name and if
that name is not used the site will redirect to it.

It's possible that your Linux machine knows the name the server
considers to be its name while the Windows 2000 machine does not.
Watch the status bar at the bottom of IE to see what name is being
tried.  Then make sure that Windows 2000 can resolve that name or
change the hostname in the nsd.tcl file to something that can be
resolved by Win2k

Posted by James Thornton on
Are you loading JavaScript into these pages?
Posted by James Cutler on
You're theory is right David!  Thanks!  Now knowing what to look for, I searched the forums here and found plenty of others who have had the same issue.  I still find it interesting that the browsers had such different responses.

Thanks again!

Posted by Cathy Sarisky on
I just dealt with this last night!  I wanted to view the pages being served by my dev box (which is on a lan and so has a private IP address and no "real" hostname) on another computer in the LAN.  I figured I could just hit AOLserver by IP address, but AOLserver wants to redirect you to whatever it thinks $hostname should be, which is a problem if you don't have any DNS for that hostname!  It seems to me that the "out of the box" nsd.tcl file should probably NOT grab hostname from the machine, since the user's first attempt to configure openACS will almost certainly be on a dev box, which may or may not have a real host name.

Alternately, I think that the nsd.tcl needs a comment describing AOLserver's desire to redirect any requests to whatever hostname is.  AOLserver's behavior in the presence of an incorrectly set hostname is funky enough that it isn't obvious what needs to be fixed, only that SOMETHING is broken.

Posted by James Thornton on
I had the same experience last week (see

I tried to fix it by commenting out the hostname variable in nsd.tcl, leaving only the IP, but things did not improve until the hostname went live.