Forum OpenACS Q&A: RedHat 7.1 RPM errors

Posted by Craig Hollenbach on
when installing OpenACS 3.2.5 from binary Red Hat 7.1 RPMs, (listed
at, I got
the following errors:

error: failed dependencies:

postgresql = 7.0.3 is needed by postgresql-devel-7.0.3-8

postgresql = 7.0.3 is needed by postgresql-jdbc-7.0.3-8

postgresql = 7.0.3 is needed by postgresql-odbc-7.0.3-8

postgresql = 7.0.3 is needed by postgresql-perl-7.0.3-8

postgresql = 7.0.3 is needed by postgresql-python-7.0.3-8

postgresql = 7.0.3 is needed by postgresql-tk-7.0.3-8 is needed by postgresql-tk-7.0.3-8

The rpms I tried installing are:










Postgres has never been installed so no Postgresql replacements were

Thanks for any help.  -craig

Posted by Jonathan Marsden on

My whichfilesdoineed.html should not mention PG 7.0.3 at all.

Use only PG 7.1.x as listed, not PH 7.0.x from your RH install. I think you installed PG 7.0.3 from your Red Hat CDs. Undo that

rpm -e `rpm -qa |grep postgresql`

and then try installing per my document.

Posted by Jonathan Marsden on
Oops, broken link in my previous post. The doc is at

I just looked and I'm now sure it doesn't recommend installing PG 7.0.x anywhere in it. So that's definitely the issue you are facing. Somehow, accidentally or otherwise, you (or someone else with root access to your machine!) managed to install PG from your Red Hat CDs, and it is now getting in the way.

BTW, in case you ever actually started it up inadvertently too, you may want to do

  /bin/rm -rf /var/lib/pgsql

after you do the rpm -e command I suggested earlier.

Posted by Jonathan Marsden on
Craig, did you ever get this solved?  I'd appreciate the feedback, in case others run into this in future.  I'd also appreciate confirmation that in fact PG 7.0.3 *was* already installed, just so I am sure that was the cause of the problems you saw.  Thanks!
Posted by Craig Hollenbach on
Jonathan, I do not have this problem solved, but I am further along than I was.  Yes, I had postgres 7.0.3 on my machine when I tried to install the rpms.  I took your suggestions, but encountered the following errors when trying to remove postgres 7.0.3:

        Postgresql is needed by php-pgsql-4.0.4p11-9 is needed by perl-DBD-Pg-0.95-1 is needed by php-pgsql-4.0.4p11-9
        Postgresql-devel >= 7.0 is needed by perl-DBD-Pg-0.95-1

I sent you email under a separate email, but have not heard back from you.  thanks.

Posted by S. Y. on
Postgresql is needed by php-pgsql-4.0.4p11-9 is needed by perl-DBD-Pg-0.95-1 is needed by php-pgsql-4.0.4p11-9 Postgresql-devel >= 7.0 is needed by perl-DBD-Pg-0.95-1

This indicates that someone with root access installed the following packages on your system:

  • php-pgsql-4.0.4p11-9
  • perl-DBD-Pg-0.95-1

You have additional software dependency issues. You need to remove these packages first:

    rpm -e php-pgsql perl-DBD-Pg

then you should be able to remove postgresql 7.0 packages.

Alternatives: or you could look for newer postgres 7.1 compatible versions of these two packages. Or, if you're confident, you can use brute force by invoking rpm's --nodeps --force flags and just cram the software into your system.

Posted by S. Y. on
N.B. software dependencies with Red Hat RPMs can be cascading. Therefore, if you're trying to remove foo and foo-devel and rpm says you that you need to remove goo and goo-devel, you'll have to remove goo and goo-devel. However, rpm may then indicate that boo and boo-devel requires goo and goo-devel. Unfortunately, rpm is more or less too stupid to indicate/manage cascading software dependencies. You have to deal with these case by case and hopefully correctly decide when you can blow by dependencies, or when you need to maintain integrity.

Managing software conflicts is a basic part of the *nix sysadmin's life. Revelant experience accumulated over time is really the only way to learn this stuff. Welcome to *nix and good luck.

Posted by Jonathan Marsden on

It sounds as though PG 7.0.3 was not the only thing you somehow installed by accident! A little more attention to detail during the installation of your OS would probably have bene helpful?

Anyway, now the basic issue becomes, do you need all of that stuff which rpm says is dependent on PG 7.0.3, or not? Do you use any of it? If not, then just uninstall it with rpm -e whatever . If you are really using PHP with PG drivers, and/or the Perl DBD interface to PG, then you are already using PG 7.0.3, so stop and think before you remove PG 7.0.3 and related software.

If you need to check what a particular rpm that is installed is for, because you are unfamiliar with it, the command rpm -qi rpmname will display a brief summary about the package.

Posted by Gilbert Price on
Maybe this will help, I loosly follow the instructions contained in this document <a href=""></a> when installing Redhat, specifically I currently use the Redhat 7.1 distro, the only package I add to those recommended in this document is the "Image Manipulation" package.

<p>You basically get a basic environment with all advance features (web server, RDBMS, advanced networking) still needing to be installed, exactly what we need for setting up OpenACS.

<p>This has proven useful to me in that unintended packages don't end up getting installed and causing me more problems later.

Posted by Craig Hollenbach on
I removed the php and perl rpms, as sean suggested, and re-executed the rpms.  All seems to be working.

Many thanks to the openacs community and those who responded in particular.  This is my first exposure to such a group.  I am very favorably impressed with your responsiveness and helpfulness, especially given my lack of experience.