Forum OpenACS Q&A: Response to RedHat 7.1 RPM errors
Postgresql is needed by php-pgsql-4.0.4p11-9 Libpg.so is needed by perl-DBD-Pg-0.95-1 Libpg.so is needed by php-pgsql-4.0.4p11-9 Postgresql-devel >= 7.0 is needed by perl-DBD-Pg-0.95-1
This indicates that someone with root access installed the following packages on your system:
You have additional software dependency issues. You need to remove these packages first:
rpm -e php-pgsql perl-DBD-Pg
then you should be able to remove postgresql 7.0 packages.
Alternatives: or you could look for newer postgres 7.1 compatible versions of these two packages. Or, if you're confident, you can use brute force by invoking rpm's --nodeps --force flags and just cram the software into your system.