Forum OpenACS Q&A: Oracle 10g/Fedora Core 3

Posted by howard snyder on
I just want to make sure...before I spend a lot of time for nothing.

Will ACS work with Oracle 10g on a Fedora Core 3 installation?

Howard Snyder

Posted by Jade Rubick on
I think it hasn't been tested well on Oracle 10g, but I imagine it should work with some minor bugs. I personally will be doing this at some point on my dev laptop.

If you do find any bugs, feel free to commit fixes or patches via the bug-tracker.

Posted by Cynthia Kiser on
We just tried to compile nsoracle 2.7 against Oracle 10g with 0 luck. But looking at the cvs repository version of the Makefile, it looks like one might have some better luck with 2.8.beta1 (AKA cvs HEAD). Will give it a go tomorrow and report back.

Anyone who has already succeeded, feel free to jump in and tell us all about it.

Posted by Jose Pablo Escobedo Del Cid on
Here at uc3m we recently compiled nsoracle 2.7 against Oracle 10g and succeeded, we just replaced the line:

MODLIBS = -L$(ORACLE_HOME)/lib -lclntsh -lcore9 -lcommon9 -lgeneric9 -lclient9


MODLIBS = -L$(ORACLE_HOME)/lib -lclntsh -lcore10 -lcommon10 -lgeneric10 -lclient10

and that was it. (If you are not using the source code to compile aolserver, you must need to change the NSHOME var too, and assign the right path to it)

I hope this helps.


Posted by Don Baccus on
nsoracle 2.8 may not be compatible with OpenACS, at some point the new maintainer took out some stuff we need, I'm not clear on the status but you have been warned...

Since nsoracle 2.7 works fine when compiled with the changes to the make file mentioned by Jose Pablo, I'd recommend you just use it ...

Posted by Connie-Lynne Villani on
Using both nsoracle 2.7 (with the makefile changes) and 2.8, we got a ton of warnings at compile time. No errors, though, so we soldiered on...

Unfortunately, nsoracle won't load at startup (from the logs):
[14/Apr/2005:02:06:05][2992.3086952672][-main-] Warning: modload: could not find Ns_ModuleInit in /software/stow/ao
[14/Apr/2005:02:06:05][2992.3086952672][-main-] Fatal: modload: failed to load module '/software/stow/aolserver/bin

Any idea how we should proceed?

Connie-Lynne (I work with Cynthia; this is the same installation she references above)

Posted by Connie-Lynne Villani on
We think our problem is related to some warnings we get when trying to build nsoracle:

[root@holden nsoracle-2.7]# make
gcc -pipe -I/u01/app/oracle/product/10.1.0/Db_1/rdbms/demo -I/u01/app/oracle/product/10.1.0/Db_1/rdbms/public -I/u01/app/oracle/product/10.1.0/Db_1/network/public -I/u01/app/oracle/product/10.1.0/Db_1/plsql/public -O -D__NO_STRING_INLINES -D__NO_MATH_INLINES -Wall -Wno-implicit-int -fPIC -I/software/stow/aolserver-4.0.10/include -I/software/stow/tcl-8.4.6/include -DNO_CONST -DHAVE_UNISTD_H=1 -DHAVE_LIMITS_H=1 -DTCL_THREADS=1 -DUSE_THREAD_ALLOC=1 -D_REENTRANT=1 -D_THREAD_SAFE=1 -DHAVE_PTHREAD_ATTR_SETSTACK\
nsoracle.c:272: warning: conflicting types for built-in function 'log'
nsoracle.c: In function `Ns_DbDriverInit':
nsoracle.c:897: warning: passing arg 3 of `log' discards qualifiers from pointer target type
nsoracle.c:901: warning: passing arg 3 of `oci_error_p' discards qualifiers from pointer target type
nsoracle.c:907: warning: passing arg 3 of `error' discards qualifiers from pointer target type
nsoracle.c:918: warning: passing arg 3 of `log' discards qualifiers from pointer target type

...and so on with warnings about arg 3 of log for what appears to be most functions in the module.

We've tried the following options to get nsoracle 2.7 to compile and build properly:

NSHOME set to /install/src/aolserver-4.0.10 (our source directory)
NSHOME set to /software/stow/aolserver-4.0.10 (our build directory)

Neither of these appear to make a difference in terms of the number of warnings we get when building nsoracle. I've also set AOLSERVER to both those values, and tried all four combos of those values, and we still get the warnings. Just for kicks, I also set the following environment variables:


Again, we still got the "type mismatch" error message on build, and the fatal error message about nsoracle being unable to load (because it can't locate Ns_ModuleInit) when starting AOLserver.

Any idea what we can do? Jose, you said you got it running, could you give us some more details? We're on RHEL 4.0, for the record.


Posted by Jose Pablo Escobedo Del Cid on
I forgot to say that we're using Debian, I just followed the instructions at and debian), I also set all the environment variables, just as in de documentation, and I don't remember getting so many warnings.

I'm sorry I can't help you more. Ypu could try searching for RHEL specific documentation ( maybe?).

Good luck! =)

Jose Pablo

Posted by Cynthia Kiser on
Thanks. Oracle installed fine. Our problems are with compiling the nsoracle driver. But since you say you have had success, we'll poke around some more and see if we can figure out why ours doesn't compile correctly.
Posted by Cynthia Kiser on
Well I am still a little concerned about the warnings. But the fatal loading error was in the way we were trying to load the module. The kind folks on the AOLserver IRC reminded me that one does not load the nsoracle driver in the modules section - instead you load, and then it loads the driver specified in the ns/db/drivers section. Much better now! I can select sysdate from dual. Now for some ACS testing (and perhaps even some OACS/dotLRN testing if I get to it).
Posted by howard snyder on
I have Oracle up and running.
I have AOLServer up and running, without trying to load the oracle driver.
I compiled the oracle driver OK.
I duly note the warnings on the config.tcl file and I think I have it right.
So why am I getting "could not find Ns_ModeInit" error when I brave out into the oracle driver world world?

Howard Snyder

Posted by Jade Rubick on
Hi Howard:

I posted a few bug fixes to the OpenACS installation on HEAD, but I wasn't getting the error message you were so perhaps this is irrelevant to you.

Posted by howard snyder on
I succeeded in having AOLServer load nsoracle 2.7 but carefully following message of Cynthia Kiser from 4/15.

What do I put (in the .tcl config file) as the Datasource for Oracle? Localhost/localdomain?

Howard Snyder...

ps Nick and Steve say hi to C. Kiser.

Posted by Andrew Piskorski on
Howard, no, absolutely not. (AFAIK this stuff is all exactly the same for 8i, 9i, and 10g, btw.)

If AOLserver and the Oracle RDBMS are on the same box, you can just set ns_param DataSource to empty string, which will use the Bequeath connection method.

If they are on different boxes, you must make sure that the Oracle listener is configured properly, and then set ns_param DataSource to the proper SID, "ora10" or whatever else you named it.

Posted by howard snyder on
Thank you Andrew, that worked.

By the way, may I ask an Oracle question?
I keep getting "The Network Adaptor could not establish the connection" error when I try to access Oracle Enterprise Manager (from a remote machine). What are the proper settings for the tsanames and listener files?


Posted by Andrew Piskorski on
Howard, I'm not sure; I've certainly never used Oracle Enterprise Manager. Check my Oracle notes, if it's not in there I probably don't know the answer.
Posted by Mel Lord-Lloyd on
I'm running AOLServer 4.0.7 built 07/22/2004 on WindowsXP w/Tcl 8.4, with Oracle 10g as the database. I'm not having any luck compiling the driver. Has anyone compiled the nsoracle.dll driver for use with WindowsXP/Oracle? If so, could you please post a copy of it someplace where everyone else can use it.


Posted by Martin Elsman on
I have troubles linking in oracle dynamic libraries when trying to build and install the nsoracle 2.7 driver. Even after having installed oracle-xe and oracle-xe-client ( using apt-get, I have troubles locating the libraries

-lcore10 -lcommon10 -lgeneric10 -lclient10

or other variants during linking. Have anyone experienced the same problem?

Posted by Andrew Piskorski on
Martin, on Ubuntu 6.06 Dapper, I compiled the nsoracle CVS head, which built fine out of the box. It seems to work with OpenACS, but I have not yet used it heavily. I don't think I ever tried the changes above to get the older nsoracle 2.7 release to build against 10g.

I don't now what "oracle-xe" is exactly, is that some 3rd party Debian or Ubuntu package for Oracle Express Edition? Do you know for a fact that it is supposed to provide the same libraries that you get with the normal Oracle 10g server?

Posted by jerry arns on

I'm facing the same problem.
I found out that libs are missing from Oracle XE.

Did you find a workaround (other than installing regular Oracle 1O.2, compile and de-install?).

Would you share your binary driver for 10.2?