Forum OpenACS Q&A: UTF-8 configuration problem (newbie)


This is my firt installation of OpenACS, and I'm having trouble with the configuration of UTF-8.

My system:
OS: Linux (SuSE Enterprise 9)
DB: Oracle (
OpenACS: 5.1.5
AOLserver: 4.0.10

The oracle database was created using UTF8. Environment variables:

The acceptance test on database was done withou errors.

The instalation os OpenACS was done without major problems, but none of the characteres like "áéçã" was shown correctly by the server.

How can I configure the server to shown these characters correctly?

My test server:

Any help will be very apreciated.

Thanks very much.

Posted by Orzenil Silva Junior on
Maybe you could try add one line to the AOLserver wrapper script to set your environment variable. Open /usr/local/aolserver/bin/nsd-oracle and add this line

export NLS_LANG=.UTF8

Check if your aolserver config file in config.tcl has setting the defaults in the ns_section ns/parameters section (it is default for OACS 5.1)

ns_param DefaultCharset utf-8

Look at this thread too. Maybe could help you on utf-8 issues although it was about aolserver3.


Posted by Abrantes Araújo Silva Filho on
Thank you Orzenil!

I done what you suggest (export NLS_LANG=.UTF8 in /usr/local/aolserver/bin/nsd-oracle) and the problem was solved.

Thank you again!