Forum OpenACS Q&A: Response to Server won't serve anything once .tcl libraries loaded at startup.

This tells us that your server is listening on port 80.
The bad request is because you typed "GET/" instead of "GET /".
This isn't really a telnet service. We are using telnet to check the web service.

You can fix this by changing ForceHostP to 0 or false (in /web/${server}/parameters/${server}.tcl) as Jonathan mentioned or by setting hostname to