Forum .LRN Q&A: .LRN 2.2.0 alpha available

Posted by Joel Aufrecht on
The .LRN release 2.2.0 alpha 1 is available as a tarball here:

It is tagged in cvs as dotlrn-2-2-0a1

Posted by Dario Roig on

Congratulations by this release. I'm try testing but the update the packages dotlrn and dotlrn Applet have the "apm_package_vers_ver_uri_un" duplicate.

ERROR:  duplicate key violates unique constraint "apm_package_vers_ver_uri_un"
CONTEXT:  SQL statement "insert into apm_package_versions (version_id, package_key, version_name, version_uri, summary, description_format, description, release_date, vendor, vendor_uri, auto_mount, installed_p, data_model_loaded_p) values ( $1 ,  $2 ,  $3 ,  $4 ,  $5 ,  $6 ,  $7 ,  $8 ,  $9 ,  $10 ,  $11 ,  $12 ,  $13 )"
PL/pgSQL function "apm_package_version__new" line 37 at SQL statement

                select apm_package_version__new(
                        'A Course Management System',
                        'Course Management',
Database operation "0or1row" failed (exception NSDB, "Query was not a statement returning rows.")


Posted by Victor Guerra on
That is because the url was not changed in the file :P ( maybe Joel missed that one when taking up versions for the release).

it should be url="";

instead of utl="";

i commited the change. So feel free to update your code.

Victor Guerra.

Posted by Rafael Calvo on
Reporting an installation problem

After installing dotlrn packages and try to restart the server from within the install page I get:

invalid command name "curriculum::curriculum_filter"
while executing
"$proc $conn $arg $why"
invoked from within
"set result [$proc $conn $arg $why]"
("uplevel" body line 2)
invoked from within
"uplevel $code"
invoked from within
"ad_try {
set result [$proc $conn $arg $why]
} ad_script_abort val {
set result "filter_return"..."

I had to kill the nsd process from the command line.



Posted by dennis sacks on
dotlrn 2.2a1
curriculum 1.5

on the class control panel - at the bottom of the page this shows up:

Error in include template "/var/lib/aolserver/bunchy/packages/curriculum/lib/bar": site node not found at url ""

Also, a curriculum applet is not listed in the 'manage applets' section.

any thoughts about what might be wrong?


Posted by dennis sacks on
I am having problems with the lorsm applet in .LRN 2.2.0 alpha.

On the Class Home page under Learning Materials, the class course link doesn't work. I've tried importing the SCORM course into lors-central and associating. I've also tried directly importing a SCORM course into lorsm. Same result. The link is bad - it gives a "file not found" page.

The html source for the link is:

<a href="{/dotlrn/classes/$mathematics/$mathematics.algebra1/algebra1/lorsm/}delivery-scorm/?man%5fid=4204" title="Access Course">Algebra 1</a>

Daveb was looking at the source and he said:

daveb: aha
(10:12:33) daveb: look at this
(10:12:33) daveb: <a href="${lors_central_url}one-course?item_id=@d_courses.item_id@">[_ lors-central.add_mat]</a>
(10:12:48) daveb: it has ${} in the display_template property of the list
(10:12:59) daveb: and tcl code
(10:13:01) daveb: just as you see

Posted by Malte Sussdorff on
Ups, I forgot to commit this bugfix... Been there, done it.

Interestingly though I'm not getting the pictures.

Posted by dennis sacks on
is this fix now in cvs? How do I check out lorsm from cvs?
Posted by dennis sacks on
I pulled lorsm from cvs. The course link under Learning Materials has a different URL now, however it still gives me a 'file not found' page when I click it.

The url path is /dotlrn/classes/$mathematics/$mathematics.algebra1/algebra4/lorsm/delivery-scorm?man%5fid=3529

I don't even know what the path should be to reference the course in LORS.