Forum .LRN Q&A: How to upgrade .LRN from 2.2.1 to 2.41

Request notifications

I need to upgrade a .LRN 2.2.1 installation to a 2.4.1
Have you any suggestion ?
have you a check list of activities to be made ?
Collapse
Posted by Emmanuelle Raffenne on
Hi Claudio,

I would recommend not to upgrade directly from 2.2 to 2.4, although it should work fine, but to do it incremental, i.e. from 2.2 to 2.3 then from 2.3 to 2.4

By the way, since you are going to upgrade, why don't you upgrade to the latest version, 2.5.0?

Collapse
Posted by Claudio Anelli on
Hi Emmanuelle,
thanks for your suggestions.
I think I will perform, in a test environment, a first upgrade from our 2.2.1 production environment to 2.4.1 .
If I will get some troubles il will proceed with the upgrade by release step.
I want to upgrade to the 2.4.1 because we have other production sites with the 2.4.1. Over this version we have already some expiriences, some enanchements /bug fixing for our environment and integrations
Collapse
Posted by Bunmi Taylor on
Hi

There is constant recommendation for incremental upgrade from one to the next. My colleague has upgraded directly without any any issues. From experience do know of any potential problems in doing this?

Collapse
Posted by Claudio Anelli on
Hi I have upgrade directly from 2.2.1 to 2.4.1 without any particular trouble.
Th only need that I found is the change of master template reference
Collapse
Posted by Dave Bauer on
In general the upgrade should work in one step. An issue can occur if the database version you are using is not supported in one of the versions you are upgrading from or to. In this case you'd need to upgrade to a version that is supported by your database version, and by a newer database compatible with the ultimate dotlrn version you want to use. Then upgrade the database, and finally upgrade to the target dotlrn version.