Forum OpenACS Q&A: Re: Problems defining procs

Posted by Dave Bauer on
We'll need to see the actual code to help.

Please review the error logs during startup. Grep or search for the filename that contains the procedure definition and see if there is an error while loading that file.

When you say "doesn't work" is the procedure not defined, or is it returning an error or wrong information when you try to call it?

Posted by ultra newb on
Nothing in the error logs except the same error I get when I try to access the page that tests the proc - "name of proc" isn't a procedure. Seems as if the proc is not being defined. If I define it the "normal" way (where I can't hard code info in the proc) it gets defined. If I do it the other way, it apparently doesn't.

If you want to see the actual code, at this point I've degenerated it to a simple "do nothing" proc, which still doesn't work. Here is one that doesn't work:

proc mkt {} [list return hi]

Here is another:

proc mkt {} "return hi"

I will try it the way the other poster recommends, but if that works my question would be why that works, but these other ways don't.