Forum OpenACS Development: Re: Errors Upgrading from 5.5 to 5.8 (:acs::pageroot": no such variable)

During upgrade of the Kernel, the sql function apm__register_parameter/10 is supposed to be installed.
is there any reason, why you used /acs-admin/install/install?upgrade_p=1 and not acs-admin/apm/packages-install?

When going to acs-admin/apm/packages-install, click on ACS Kernel, then you will be forwarded to a page acs-admin/apm/packages-install-3, where it says "Select what data files to load for Kernel ...". There, the mentioned upgrade script should be listed. When you continue there, you should see the following lines in the log:

... Notice: ***Installing Kernel ...
... Notice: - Installing data model for Kernel ...
... Notice: - Loading data model ....upgrade...
... Notice: - Loading data model ....upgrade...
... Notice: Installed Kernel, version ....

I can't exclude that "upgrade from local" might be broken.

Please, check, what upgrade scripts are loaded in your installation. The easy fix for you installation is to run the upgrade script manually, but we should aim for a general solution, maybe someone else has the same problem.


Posted by Cesareo Garci­a Rodicio on
I use /acs-admin/install/install?upgrade_p=1 instead of acs-admin/apm/packages-install because "Install Software" link in Main Admin Page (acs-admin). So I think that the only reason may be lazyness :-)

I've just tried using acs-admin/apm/packages-install and Kernel was installed correctly but after that, when It was installing acs-tcl same error occurred.

I also realized that my Kernel version was Kernel 5.5.0d6 (not 5.5.1) so I did a Kernel upgrade (to 5.5.1) and tried again but ... same error

BUT I'll tried again with these strategy ( I have read that it is the recommended way but my lazyness comes out :-) ).

I'll do an "Upgrade from repository" to get my dev server to 5.7. And, after that I'll try again with "Upgrade from local" to get 5.8.0 work.

I'll keep you informed to know what it the "general solution" (I think it could be "have a minimum X version installed").

If you want to look for testing an "straight upgrade from 5.5.1 to 5.8" I can do it with my dev server.

Posted by Cesareo Garci­a Rodicio on

After some weeks I'm trying to update my server again. To look for a general solution (I mean, soft upgrade via upgrade repository, I did not use cvs method) I did:
- Upgrade vía http://localhost:8080/acs-admin/install/ (Upgrade From Repository)
- And the same error came out (sql function apm__register_parameter stuff)

I saw upgrade-5.6.0d6-5.6.0d7.sql

This error came out firstly when I tried to upgrade tclwebtest

--------- Logs --------------
Notice: Extracting the .info file (acs-automated-testing/
[18/Oct/2013:18:23:28][53661.279633920][-default:6-] Notice:

  • Extracting files into the filesytem.
    [18/Oct/2013:18:23:28][53661.279633920][-default:6-] Notice:
  • Automated Testing 5.6.0 ready for installation.
    [18/Oct/2013:18:23:28][53661.279633920][-default:6-] Notice:

    Installing Automated Testing 5.6.0

    [18/Oct/2013:18:23:28][53661.279633920][-default:6-] Notice: Loading packages/acs-automated-testing/tcl/aa-test-procs.tcl...
    [18/Oct/2013:18:23:28][53661.279633920][-default:6-] Notice: Loaded packages/acs-automated-testing/tcl/aa-test-procs.tcl.
    [18/Oct/2013:18:23:28][53661.279633920][-default:6-] Notice: Loading packages/acs-automated-testing/tcl/example-procs.tcl...
    [18/Oct/2013:18:23:28][53661.279633920][-default:6-] Notice: Loaded packages/acs-automated-testing/tcl/example-procs.tcl.
    [18/Oct/2013:18:23:28][53661.279633920][-default:6-] Notice: Loading packages/acs-automated-testing/tcl/filter-procs.tcl...
    [18/Oct/2013:18:23:28][53661.279633920][-default:6-] Notice: Loaded packages/acs-automated-testing/tcl/filter-procs.tcl.
    [18/Oct/2013:18:23:28][53661.279633920][-default:6-] Notice: Loading packages/acs-automated-testing/tcl/selenium-procs.tcl...
    [18/Oct/2013:18:23:28][53661.279633920][-default:6-] Notice: Loaded packages/acs-automated-testing/tcl/selenium-procs.tcl.
    [18/Oct/2013:18:23:28][53661.279633920][-default:6-] Notice: Loading packages/acs-automated-testing/tcl/tclwebtest-procs.tcl...
    [18/Oct/2013:18:23:28][53661.279633920][-default:6-] Notice: Loaded packages/acs-automated-testing/tcl/tclwebtest-procs.tcl.
    ERROR: function apm__register_parameter(unknown, unknown, unknown, unknown, unknown, unknown, unknown, unknown, unknown, unknown) does not exist at character 15
    HINT: No function matches the given name and argument types. You might need to add explicit type casts.

    select apm__register_parameter(
    'Browsers to test with. Default *firefox',
    ----- End log apm__register_parameter Thing ----

    After that everything seems to be broken (a lot of errors).

    **Side Note** (I think it is off this topic but just in case):

    1. I couldn't upgrade Localization and Subsite Packages
    Package Version Error Message
    Localization 5.6.0 Requires ref-countries 5.6.0; ref-language 5.6.0
    Subsite 5.6.0 Requires acs-lang 5.6.0

    2. I had an error (I saw it when installing xoctl-core)

    [18/Oct/2013:18:56:49][54041.2070167936][-main-] Notice: --***** Could not retrieve argument name for survey_response__initial_user_id argument 1 from line 'p_response_id alias for $1;' in
    p_response_id alias for $1;
    v_user_id integer;
    select into v_user_id o.creation_user
    from acs_objects o,
    survey_responses s
    object_id = coalesce(s.initial_response_id, s.response_id)
    and s.response_id = p_response_id;
    return v_user_id;
    [18/Oct/2013:18:56:49][54041.2070167936][-main-] Notice: We cannot handle object_name = 'set' in this version, ::xo::db::sql::organization ::xo::db::Class->dbproc_nonposargs (0ms)
    [18/Oct/2013:18:56:49][54041.2070167936][-main-] Notice: ---- no aliases for ab_contact__delete_orphan_address/1

  • Collapse
    Posted by Gustaf Neumann on
    If one wants to upgrade the OpenACS kernel of a pre-existing installation from 5.5 to 5.8, and chooses to "install/upgrade from repository", then one stays in the same OpenACS branch (like oacs-5-5). The installer offers newer versions from the same branch. So, i am not sure from what state to which other state you try to proceed.

    When installing new version of the kernel, one has to use either the tar file or a CVS checkout.

    In case you have a broken update (e.g. the kernel reports to be in openacs 5.8, and you do not have apm__register_parameter/10 in your database), then one can either fix the database, or try to figure out, what went wrong during the upgrade. Fixing means to source the upgrade file mentioned above with "psql -f ..."

    In order to try to find the cause of the problem you are experiencing, one needs the old state of the database (e.g. a backup) and continue from there, look whether the upgrade script in question is sourced when upgrading the kernel, etc.

    The message from xoctl-core is not an error, but a warning and says that you can't call that particular function from survey via the ::xo::db interface, something you do not want probably anyhow.

    Posted by Cesareo Garci­a Rodicio on

    Ok, I was doing totally wrong :-). I thought I could upgrade via "upgrade from repository" between main releases (i.e 5.5 to 5.6) (My lazyness took my to thing that changing url arguments, upgrade would be faster :-) )

    I'll try to upgrade using CVS checkout / tar files between releases. Firstly to upgrade to 5.6, then 5.7 and finally to 5.8. I'll keep my results here

    Thanks so much!