Forum OpenACS Q&A: Error loading acs-mail-lite-procs.tcl

Request notifications

I've reinstalled oacs-core from HEAD, and installed acs-mail-lite package but got an error when loading acs-mail-lite-procs.tcl library:

Error: Error sourcing /web/ora-openacs/packages/acs-mail-lite/tcl/acs-mail-lite-procs.tcl:
can't find package mime 1.4
while executing
"package require mime 1.4"
(file "/web/ora-openacs/packages/acs-mail-lite/tcl/acs-mail-lite-procs.tcl" line 11)
invoked from within
"source $__file "

acs-mail-lite-procs has those lines:

package require mime 1.4
package require smtp 1.4
package require base64 2.3.1

I've grep'd all core packages for "package provide (mime|smtp|base64)" but none provides them.

Any idea of what library should provide those packages?

Collapse
Posted by Dave Bauer on
You need to install Tcllib somewhere that aolserver can find it. Probably the same place tdom is installed would work well.

Tcllib is required in OpenACS 5.3. (http://openacs.org/forums/message-view?message%5fid=298282)

http://www.tcl.tk/software/tcllib/

There are version of tcllib for every distribution that supplies Tcl (I believe that's all of them.)

Previously tcl files from tcllib were copied and distributed with OpenACS but this makes it very hard to maintain those files, and since AOLserver 4 works with "package require" its much easier to use the official tcllib files.

Collapse
Posted by Emmanuelle Raffenne on
I've got tcllib 1.6 allready installed but I think aolserver is not aware of it. How should I configure it? (i'm using debian sarge stable).
Collapse
Posted by Emmanuelle Raffenne on
I found it: http://www.openacs.org/forums/message-view?message_id=443169

I updated to tcllib 1.8 also since acs-mail-lite needs tcllib >= 1.7

Thanks.