Forum OpenACS Development: Re: OpenACS 5.9 and ]project-open[
- The best way to upgrade from 5.7.0 to 5.9.0 should go via 5.8.0, applying  and .
- AMS is not required by OpenACS 5.9.*. When the mentioned upgrade script, or actually content_type__refresh_view() is failing, this means that the acs-object hierarchy is broken. There was a similar case with etp , maybe one needs a similar fix for ams. The right way to upgrade with etp is to upgrade to the recent version of etp in oacs-5-8, then the 5-9 upgrade will work.
- ITU Code: the error says that the postgres sql-commands are not compatible with the pg 9 version. Do you need this package, or do you have just laying it around for historical reasons?
- ams and itu-ref do not belong to the 90 packages i am trying to maintain.
- concerning page-error.tcl: this include file is called from the request-processor passing the context variables in. Do you use a modified request-processor? Or are you calling the include from different places? Then please provide the appropriate context as shown in the request-processor procs. This include file is actually a good example, where a include-contract (new feature in oacs-5-9) should be used to make the variable expectations of the include-file clear.
hope this adresses most issues.
- Patches: Ok, we're on the oacs-5-9 branch anyway, so I understand that we'll get your PUT and DELETE patches in ad_register_proc?
- ITU Code: I needed to install this package as a dependency. I don't remember exactly which package, I believe AMS... Glad to remove the package
- page-error.tcl: The variables in page-error are one subject, we can deal with this. However, we need a customized version of page-error in order to deal with our ]po[ error reporting system. => Could you create a parameter similar to LoginTemplate, so that we can use a different page-error.tcl without having to customize OpenACS?
Btw., I've got ]po[ now running with OpenACS 5.9. We're going to do some testing and probably come up with some more issues.