Forum .LRN Q&A: Re: Assessment package

11: Re: Assessment package (response to 9)
Posted by Matthew Coupe on
Once I'm booted up I'm now getting

invalid command name "auth::require_login"
while executing
(procedure "ad_maybe_redirect_for_registration" line 2)
invoked from within
invoked from within
"set user_id [ad_maybe_redirect_for_registration]"
("uplevel" body line 40)
invoked from within
"uplevel {

12: Re: Assessment package (response to 11)
Posted by Roel Canicula on
I encountered the same problems when I upgraded to Fedora Core 6.

I tried different combinations of AOLServer 4.0.10, 4.5.x, from CVS and tcl <= 8.4.6, 8.4.13, .14, CVS but never got xowiki working and got intermittent server crashes.

Here's how I solved it:

- Downgraded bash (FC6 comes with bash-3.1, I downloaded the bash-3.0.x source, compiled it, symlinked /bin/sh to the compiled bash binary)

- Used tcl-8.4.6 instead of tcl-8.4.13 that comes with FC6 (it's unfortunate coz the tcl in FC6 already has threads enabled)

Now everything works perfectly with aolserver-4.0.10, xotcl-1.5.2 and the latest xowiki and xotcl-core from HEAD.