Forum OpenACS Q&A: openacs/aolserver is not seen on Internet while testing

Hello everybody.
I installed, configured and tested openacs-3.2.5 on my RH linux-7.1
box. I run aolserver -3.4.2 from daemontools.
This is my development machine.  I have no problem in accessing my
site from port 8000 as well as from 80 from "my
mchine"( I connected to the Internet and with that
"dynamic IP address", I tried to connect to my machine from a second
machine via Internet. But the index page of my site was not seen.
Then I stopped aolserver and started httpd (apache); reloaded the
page; the other index page from apache is seen.

I set up this machine as a "dial - in server". And from another
computer I dialed to this machine, and my site using openacs and
aolserver was there. (for 80 / 8000) and using MSIE and Konquerer.

I am confused. aolserver is not accessible from any of the ports (
80 or 8000) from the "Internet." I have not set up any kind of

I  have arranged a demonstration of my site using openacs via
Internet to one client and I am stucked. How can I make my site
visible from the Internet using dynamic Ip address and on port 80 ?
Please help me.
Thanking you all.

Does your log say something like this?

[27/Aug/2002:01:00:51][11967.1024][-main-] Notice: nssock: listening on

I've never heard that nsd could listen on two ports simultaneously.  You may want to try just one.

Does netstat show that the ports are being listened on?

Hi Jonathan.
My machine does say like
[28/Aug/2002:13:07:07][3885.1024][-main-] Notice: nssock: listening
on where is my machine's IP address.

I get a dynamic IP address from my ISP. What I want is
when anybody who knows this address, should type
in his browser and could see my site.

My other site on apache on my machine is seen by this method. What
is problem with aolserver then ?

Does your AOLserver config file have this setting?:
set address [ns_info address]

You might try changing that to:
set address ""

I'm guessing that [ns_info address] returns your machine's LAN ip (?) rather than the internet ip you want AOLserver to listen to. I don't know what system setting affects what [ns_info address] returns, but fixing the setting to "" may be fine if your ip doesn't change frequently.

Do you have a reverse proxy? If not how can anyone see your private internal address?
How I did it in dial-up/ISDN land:

1.  Get an account with or one of the similar free dynamic dns companies.

2.  Get a router (or dust off an older Pentium I).  There are lots of OTHER reasons to get a router also, but one is that your AOLserver doesn't have to notice when the IP changes.  (Cheap used routers may be had via your favorite online auction house.)  Tell your router to direct anything sent to port 80 (or 8000) to your web server.

3.  Don't tell AOLserver what IP to listen on, or tell it to listen on

You could probably skip steps 1 & 2 and JUST do step 3, actually.  I'm just a big router fan, since I have 5 machines (six if you count the Audrey in the kitchen) sharing one dynamic IP.


Oh, and...

You can get AOLserver to listen to two IPs (if for instance you had 20 on the machine but didn't want it to take ALL of them by grabbing by having two sets of nssock entries.  (Call the second one nssock2 or something, but use for both.)  I did this with a bunch of vservers when we were transitioning from one block of IP space to another.

As per the suggestions, I first told the AOL server to listen on and later on ( the dynamic IP address I got
from my ISP ). Later I changed the SystemURL in
Openacs config file. In all these cases the browser from other
computer gets connected to my site but tells that index page is not
available. The access.log file says something like - - [31/Aug/2002:17:48:59 +0530] "GET / HTTP/1.1" 302
311 "" "Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)"
Does this means that an error page is sent but is not visible  (302
) ?

302 is a redirect.  do you have ForceHostP turned on in your parameters file?