Forum OpenACS Q&A: Re: Recommended version of PostgreSQL?

Posted by Antonio Pisano on
When upgrading OpenACS versions <= 5.8, one should use a Postgres 8.* (e.g. latest Postgres 8.4)

One should then dump the resulting 5.8 database, restore on a later Postgres version (any supported version, such as the one from your distro package manager should be fine) and proceed with the upgrade to 5.10.*

I just had experience about such an upgrade from an old OpenACS 5.4.* to 5.10.*, which was successfull (save the expected fallouts and adjustments).