Forum OpenACS Q&A: Re: Problem with newest xowiki

Posted by Eduardo Santos on
Hi people,

When updated my xowiki and followed the instructuions, it was alright. However, when I started a new instance and tried to put the same xowiki that was already working, it gives me the errors above. I went to the shell and tried to run the procedure ::xo::db::has_ltree and the answer was totally unexpected:

invalid command name "::xo::db::has_ltree"
while executing
("uplevel" body line 1)
invoked from within
"uplevel 1 $script"

I have no idea about what's happening. Can anybody give me a clue?

Posted by Gustaf Neumann on
Most probably, your installation is missing the file xotcl-core/tcl/05-db-procs.tcl
which is part of xotcl-core since 4 weeks.
Posted by Eduardo Santos on
You are absolutely right. Thanks again. I have an internal version control with subversion, and when I updated the packages in my repository I just commited the changes and forgot to add the new files. Thank you very much again.