Forum OpenACS Q&A: Unable to connect OpenACS from another pc


I'm looking for connecting me to OpenACS installed on my server from a pc of my local area network but when i'm putting the right adress with the port of my server (Redhat linux 7.3). I've got no response not even an error message from AolServer, simply the error page I used to have in IE.

Don't know what it's happening :/

Any ideas ?


Etienne Tchou

Posted by Brian Fenton on
It could be your network proxy settings. If you're using IE, check under Internet Options, Connections, LAN Settings, Proxy Server, Advanced, and enter the IP address or HOSTS entry of the machine your AOLserver is running from into the list under "Do not use proxy server for addresses beginning with".

This is assuming you're using a Proxy server and you've ticked "Use a Proxy Server" under the LAN settings.

Does this help?

Posted by Chino Moreno on
Nope sorry, it doesn't work ...

I've installed Redhat CCM and resin works perfectly with IE
but Aol Server doesn't work. Any other solution ?


Posted by Jeff Davis on
you should check if it is actually starting up and listening on the port you think. You should see a line like
[29/Oct/2002:22:56:42][28143.1024][-main-] Notice: nssock: listening on
Posted by Chino Moreno on
[nsadmin@localhost aolserver]$ [21/Nov/2002:18:14:49][1627.1024][-main-] Notice: nsd.tcl: starting to read config file...
[21/Nov/2002:18:14:49][1627.1024][-main-] Warning: nsd.tcl: nsssl not loaded because key/cert files do not exist.
[21/Nov/2002:18:14:49][1627.1024][-main-] Notice: nsd.tcl: finished reading config file.

I've just that. Where can I info on configurate my Aolserver ?


Posted by Tilmann Singer on
These are the lines that are spit out to the command line - the stuff you are looking for is in the server log (unless you run aolserver with -f in foreground mode, which can be useful when testing an initial installation).

Check out:

Posted by Cathy Sarisky on
Definitely check the server.log.

Also a netstat -ant should show AOLserver listening on the IP and port you specified.

Posted by David Walker on
Also check for a firewall running on your OpenACS machine.  Use the following 2 commands to remove any firewall rules.

iptables -F
ipchains -F

Also, if you haven't already make sure you turn off "Show Friendly HTTP Error Messages" in your Internet Explorer configuration.

(That setting would be more accurately called "Hide Relevant Info and Cause Mass Confusion" but I doubt they'll change the name for me)

Posted by Chino Moreno on
It looks so strange ...

I can connect to OpenACS on my local server and it's working but when I try to access it from another pc ... this one cannot give me a page.

I've got looked the server.log : every seems to be ok. And Aolserver is listening on the required port.

I've got stopped iptables/ipchains but I still have the same message on windows.

I'm sorry but I don't understand what happens ...
Resin and Tomcat work well on this machine.


Posted by Brian Fenton on
It definitely sounds like a browser issue. Can you try Mozilla or Netscape? Have you turned off "Show Friendly HTTP Error Messages" in your Internet Explorer configuration? The next thing to try is to by-pass your browser completely and telnet directly into the web server:

telnet 80
GET / HTTP/1.0

(press Return twice)

What comes up when you try this?

Posted by Chino Moreno on
it's werd !

When I ping the server, i've got an answer everything is allright.

But when I try to connect on specified port with your command it doesn't work. To check, I tried on the resin port and it works.

I think it comes from AolServer but the matter is on the aolserver machine it works.

when i do a netstat -ant I've got this :
tcp 0 0* LISTEN for AolServer

It looks different for Resin !

I found the solution :
In the .tcl loaded by nsd : you have to change the adress of the server. The right adress is

It's now the same config than resin and It works on my windows.

Thanks to everyone for your help ! :)

Posted by Jeff Davis on
listening on means listen on all IP
addresses on the machine.  the IP address is the local loopback device and cannot be connected to from another
machine.  While is ok to use if its your machine it
is common to have multiple IP addresses on a server and
in that case listening on would mean no other
server could use port 8000 on any other IP address
for that reason you may want to put the actual
IP address you really want to use in explicitly.
Posted by Chino Moreno on
Thank you Jeff for these precisions