Forum OpenACS Q&A: Re: Error using __new function

Posted by Simon Carstensen on
Thank you Jun for your suggestion, but I still get the same error, although now without the long line of "unknown" parameters (so that's perhaps one step closer to a solution):
[11/Jan/2003:20:37:55][24613.4101][-conn0-] Notice: Querying '
        select na_subscription__new(
                integer '4607',
                integer '2604',
                varchar '',
                varchar '',
                varchar 'Scripting News',
                varchar 'A weblog about scripting and stuff like that.',
                integer '0',
                timestamp '2003-01-12',
                varchar 'na_subscription',
                timestamp '2003-01-12',
                integer '2604',
                varchar '',
                integer '4353'
[11/Jan/2003:20:37:55][24613.4101][-conn0-] Error: Ns_PgExec: result status: 7 message: ERROR:  Function 'na_s\
ubscription__new(int4, int4, varchar, varchar, varchar, varchar, int4, timestamptz, varchar, timestamptz, int4\
, varchar, int4)' does not exist
        Unable to identify a function that satisfies the given argument types
        You may need to add explicit typecasts
Any other suggestions as to what may solve this?