Forum OpenACS Q&A: invalid command name "template::adp_parse" w/ OpenACS 3.2.5

[02/Apr/2003:19:42:33][88185.138980352][-conn1-] Error: The page / caused the following error:
        invalid command name "template::adp_parse"

I can't, for the life of me, find anything searching the archives that *looks* pertinent, but, if there is, please point me at her ...

If I go to http://domain/index.adp, the page loads up beautifully ... if I go to http://domain, I get the above error ...

I've checked the log files, and can find no errors other then that above, which doesn't seem to help any ...

In the nsd.tcl, I've reduce the directoryfile to:

set directoryfile          index.adp

same error ...

the files are there:

ls -lL index.*
-rwxrwxr-x  1 nobody  nogroup  5866 Jan 30 17:50 index.adp
-rwxrwxr-x  1 nobody  nogroup    44 Apr  2 19:34 index.tcl

and, as I said, I can go directly to the index.adp page and it looks good (nice graphics, layout, etc, no errors), its just when trying to access it as the 'default directory file' that it generates the error ...

If I were running Apache, I'd say it almost feels like a permissions issue, but the server is run as nobody:nogroup, and I've checked permissions all the way up to /, and they look right ...

So, what am I not seeing? :(

Thanks ...

What do you get if you visit index.tcl?

Is there a 'ns_param directoryfile $directoryfile' later in nsd.tcl?

What versions of AOLserver and PostgreSQL?

And, lastly, why 3.2.5 and not 4.6.x?

44 bytes in index.tcl?  Any of this stuff available for perusal?

index.tcl: same error

ns_paran: yes ... and on a whim, since you pointed it out,I tried to hard code it as just index.adp, but makes no difference

# grep directory nsd.tcl
set directoryfile          index.adp,index.tcl,index.html,index.htm
    ns_param  DirectoryFile      $directoryfile
    #ns_param  directoryadp    $pageroot/dirlist.adp ;# Choose one or the other
    #ns_param  directoryproc    _ns_dirlist          ;#  ...but not both!
    #ns_param  directorylisting  fancy                ;# Can be simple or fancy

PostgreSQL 7.2.4 and AOLServer 3.4.2

Re: 3.2.5 vs 4.x ... its what the client developed their site under

As its not my site, not much I can offer to 'peruse' ... the index.tcl file, though, has just one line in it:

source "[ns_info pageroot]/orgs/lists.tcl"

and that file has about as much in it:

set disciplines {
    "History/Social Studies"
    "Architecture/Historical Site"
    "Visual Arts"
    "Arts Education"

set boroughs {
    "Staten Island"

Marc i don't know if it makes a difference but in your ns_param you have DirectoryFile where as normally i write it directory file i.e.

ns_param        directoryfile      "index.tcl,index.adp,index.html, index.htm"

Not sure if this will make a difference but could be worth looking into


At least for AOLserver 3.x, the config file parameter names are not case senstive, so it makes no difference.
Okay, still looking ...

The error is:

invalid command name "template::adp_parse"

searching through the tree, I'm finding that its defined in tcl/ats/parse_procs.tcl ... how/where is that file processed?  I did a 'grep -r' on the tree, and only find:

%grep -r parse-procs .
./tcl/ats/CVS/Entries:/parse-procs.tcl/1.1/Thu Mar  7 19:28:54 2002//
./tcl/ats/parse-procs.tcl.orig:# parse-procs.tcl,v 1.25 2000/10/23 17:14:00 karl Exp
./tcl/ats/parse-procs.tcl:# parse-procs.tcl,v 1.25 2000/10/23 17:14:00 karl Exp

so where is teh function supposed to be loaded? *puzzled look*

You've probably solved this by now, but for anyone searching your answer may be here!