Forum OpenACS Development: Re: xowiki 0.37 on OpenACS 5.1.5 woes

Posted by Gustaf Neumann on
First of all, make a database dump and backup packages and content repository files.

The comment about the "CVS merge" statement assumes that you have your installation in CVS and your have done local modifications. The upgrade scripts from openacs do not create a "new database", but do a stepwise upgrade of the existing installation. When OpenACS detects a new version to install (e.g. you have updates the files in the packages directory) it runs (or should run) all the necessary update-scripts, when you do a acs-admin/apm/packages-install.

I would recommend to try an upgrade to oacs-5.2.3. Start openacs with your working installation. While it is running, update the files for the acs-core packages and run then acs-admin/apm/packages-install. It will point you to the files to upgrade and will run the upgrade scripts automatically. In case something goes wrong, remember the failed update scripts and run these by hand (i.e. via psql -f ...). If you have a large database (large content repository), some steps can take a while. Once you have acs-core upgraded, then update the application packages.

Posted by Naveen Agnihotri on
The good news first: the OpenACS upgrade turned out to be quite painless. I've upgraded to OpenACS 5.2.3, and to the best of my testing, everything that worked before seems to be working. I haven't lost any data.

I am now on xotcl-core 0.48, xotcl-request-monitor 0.38, and xowiki 0.50.

Now the troublesome part: there are a couple of errors in the error.log file:

[04/Apr/2007:01:11:17][17923.1][-main-] Error: Error sourcing /home/aolserver/packages/xowiki/tcl/xowiki-procs.tcl:
 during '::xotcl::__#4 contains'
    ::xotcl::__#4 ::xotcl::Object->configure
    ::xo::OrderedComposite ::xotcl::Class->create
    ::xo::OrderedComposite ::xotcl::Class->new
    invoked from within
"::xo::OrderedComposite new -contains [my cr_attributes]"
    (procedure "init" line 8)
    ::xowiki::Page ::Generic::CrClass->init
    ::Generic::CrClass ::xotcl::Class->create
    invoked from within
"::Generic::CrClass create Page -superclass ::Generic::CrItem  -pretty_name "XoWiki Page" -pretty_plural "XoWiki Pages"  -table_name "xowiki_page" -id_..."
    (in namespace eval "::xowiki" script line 6)
    invoked from within
"namespace eval ::xowiki {

  # create classes for different kind of pages
  ::Generic::CrClass create Page -superclass ::Generic::CrItem \
    (file "/home/aolserver/packages/xowiki/tcl/xowiki-procs.tcl" line 9)
    invoked from within
"source $__file "

and a few lines below that, this one:

[04/Apr/2007:01:11:17][17923.1][-main-] Error: Error sourcing /home/aolserver/packages/xowiki/tcl/xowiki-www-procs.tcl:
invalid command name "File"
    while executing
"File instproc download {} {
    my instvar text mime_type package_id item_id revision_id
    $package_id set mime_type $mime_type
    set use_bg_deliv..."
    (in namespace eval "::xowiki" script line 256)
    invoked from within
"namespace eval ::xowiki {

  Page instproc htmlFooter {{-content ""}} {
    my instvar package_id description
    if {[my exists __no_footer]} {retu..."
    (file "/home/aolserver/packages/xowiki/tcl/xowiki-www-procs.tcl" line 11)
    invoked from within
"source $__file "

It may be irrelevant, but just in case: this is a virtual domain enabled aolserver process. I am loading libthread for both the servers.

I have a feeling I haven't configured something properly. Can you please suggest what could cause these errors?


Posted by Stefan Sobernig on
Hi Naveen!

This is probably due to the XOTcl version that you are using. The first error message shows that the actual error (message) from the lowest callstack level is suppressed. This is documented and patched for XOTcl 1.5.3. Patching or upgrading to a fresh install of 1.5.3 from should heal this problem, at least, and will show us the true source of the problem.

The second error message is a follow-up upon the first, as ::xowiki::File is declared in the same *-procs.tcl file that fails to source due to the first error.

Posted by Naveen Agnihotri on
Hi Stefan, Thanks for your response! XOTcl was already a 1.5.3, but just for good measure, I installed it again ( make distclean, ./configure..., make, make install, make install-aol), but still the same problem.

The log shows:

[04/Apr/2007:03:34:29][1708.1][-main-] Notice: XOTcl version 1.5.3 loaded

As per my previous post, this is a virtual domain enabled server, so the XOTcl loaded line occurs multiple times, once for each server. Could that be an issue?


Posted by Gustaf Neumann on
No, the reason is not the XOTcl version. Although, Stefan is right, there is a patch from January on the XOTcl mailing list, which will give in this situation a better error message, but it won't solve the problem.

I am pretty sure, you have an earlier error message in your log file. Most likely, you have oacs 5.2.3 from the released tar file. From the distance, i would think that maybe acs-bootstrap-installer/bootstrap.tcl does not have the patch in

I have included changelog of the changes in the oacs-5-2 branch after the release of OpenACS 5.2.3 below (just removed the length catalog file listings and reverted changes). These changes are as well included in OpenACS 5.3.0. I would recommend to wait until the release of OpenACS 5.3.1 and DotLRN 2.3.0, since this release contains as well updates for the application packages included in DotLRN.

There is a longer discussion about the error message you are experiencing in

Hope this helps

2007/01/04 rocaelh

* ./packages/acs-subsite/www/admin/index.adp:
* ./packages/acs-subsite/www/admin/index.tcl:
eliminating registration assessment deadlink

2007/01/02 gustafn

* ./packages/acs-reference/sql/postgresql/acs-reference-create.sql:
adding missing variable declaration needed at least for pg

* ./packages/acs-bootstrap-installer/bootstrap.tcl:
make sure to load xotcl-core init before other xowiki apps

2006/12/31 daveb

* ./packages/acs-content-repository/tcl/revision-procs.tcl:
Fix Bug#3056. sn_gifsize should be ns_gifsize.

2006/12/06 gustafn

* ./packages/acs-subsite/lib/login.tcl:
checking return_url for security reasons, don't allow
complete urls as return_urls for register

2006/12/01 victorg

Catalogs of message keys from only for
local es_ES.

2006/11/29 victorg

Adding to acs-5-2 branch, message key catalog files from
translation server for acs-core packages, dotlrn-all
packages and dotlrn-extras packages.

2006/11/22 maltes

* ./packages/acs-tcl/tcl/00-database-procs.tcl:
Made the comment about long db queries a little bit more

2006/11/18 daveb

* ./packages/acs-bootstrap-installer/db-init-checks-oracle.tcl:
* ./packages/acs-bootstrap-installer/tcl/40-db-query-dispatcher-procs.tcl:
Backport 10g recognition patches from HEAD

2006/11/16 emmar

* ./packages/acs-lang/www/admin/edit-localized-message.tcl:
Fix for #3042: patch provided by morals (raul)

2006/11/13 daveb

* ./packages/search/www/search.tcl:
Fix bug#3040, split string before passing to llength.

2006/11/03 leed

* ./packages/acs-lang/tcl/localization-procs.tcl:
Fixed bug #2952:   as thousands separator

* ./packages/acs-admin/www/users/merge-final.tcl:
* ./packages/acs-admin/www/users/merge.tcl:
Fixed bug #2999: Merge users fails.

2006/11/03 emmar

* ./packages/acs-subsite/www/user/portrait/upload-2.tcl:
Fix #2976: store comment when uploading portrait

2006/11/03 donb

* ./packages/acs-lang/www/change-locale-include.tcl:
Another file needed to fix bug #2931

* ./packages/acs-lang/tcl/lang-widget-procs.tcl:
Fixed bug #2931 ...

* ./packages/acs-kernel/
* ./packages/acs-tcl/tcl/defs-procs.tcl:
The "HomePage" parameter to acs-kernel was not localized.

2006/11/01 maltes

* ./packages/acs-tcl/tcl/text-html-procs.tcl:
translate characters into HTML codes

2006/10/31 donb

* ./packages/acs-kernel/sql/postgresql/upgrade/upgrade-5.2.0d1-5.2.0d2.sql:
Malte removed apm__register_param but did not replace it
with the correct version.

2006/10/10 maltes

* ./packages/acs-kernel/sql/postgresql/upgrade/upgrade-5.2.0d1-5.2.0d2.sql:
Made sure the correct version of apm__register_parameter is
used according to

2006/10/02 emmar

* ./packages/acs-templating/resources/forms/accessible-forms.adp:
Remove remaining / of formwidget element

2006/09/27 eduardop

* ./packages/acs-authentication/tcl/password-procs.tcl:
fix minor documentation errors

2006/08/24 emmar

* ./packages/acs-templating/resources/forms/accessible-forms.adp:
Added missing noquote for label element

2006/08/18 gustafn

* ./packages/acs-templating/www/resources/xinha-nightly/plugins/OacsFs/oacs-fs.js:
added parameter script_dir to configuration section,
defaults now to /xowiki; can be reset to the old behaviour
via e.g.: xinha_config.script_dir = '.';

2006/08/13 gustafn

* ./packages/search/www/search.tcl:
pass search_package_id to page 1 etc. as well.

2006/07/31 gustafn

* ./packages/search/www/search.tcl:
provide search_package_id as call parameter like in 5.3, to
make it easier for people to use xowiki 0.31 with oacs-5-2

2006/07/08 donb

* ./packages/acs-templating/resources/forms/accessible-forms.adp:
Olga changes to this non-standard file

2006/07/06 gustafn

* ./packages/acs-admin/tcl/apm-admin-procs.tcl:
fix for templating bug (localization) for streaming output.
Main Site was not translated in
/acs-admin/apm/packages-install; not sure, whether a generic
solution is needed... see:

* ./packages/acs-templating/tcl/richtext-procs.tcl:
* ./packages/acs-templating/www/resources/mktree.js:
make openacs usable with opera. 2 fixes: avoid multiple "+"
signs in mktree, turn off rich text editing with opera (like

* ./packages/acs-tcl/tcl/utilities-procs.tcl:
make openacs work with aolserver 4.5. address changed
behavior of ns_startcontent, works now with binary data types
as well

2006/07/03 maltes

* ./packages/acs-lang/www/admin/message-list.adp:
* ./packages/acs-lang/www/admin/message-list.tcl:
Added fast locale switch taken from categories

2006/07/03 donb

* ./www/blank-master.adp:
Fixed a "link" tag.

2006/07/01 gustafn

* ./packages/acs-tcl/tcl/utilities-procs.tcl:
Fix to make oacs work with aolserver 4.5: pass default
output encoding via content_type to ns_startcontent in case
it is not specified

2006/06/23 torbenb

* ./packages/acs-lang/sql/oracle/ad-locales.sql:
adding new locales for oracle

* ./packages/acs-lang/sql/postgresql/ad-locales.sql:
adding new locales for postgresql

* ./packages/acs-lang/
adding new locales, needs version number bumped up for

* ./packages/acs-lang/sql/oracle/upgrade/upgrade-5.2.3b2-5.2.3b3.sql:
* ./packages/acs-lang/sql/postgresql/upgrade/upgrade-5.2.3b2-5.2.3b3.sql:
adding upgrade script for new locales

* ./packages/acs-lang/sql/oracle/upgrade/upgrade-5.2.3b2-5.2.3b3.sql:
* ./packages/acs-lang/sql/postgresql/upgrade/upgrade-5.2.3b2-5.2.3b3.sql:
removing file meant for head instead of oacs-5-2 stable

* ./packages/acs-lang/sql/postgresql/ad-locales.sql:
reverting to oacs-5-2 stable

* ./packages/acs-lang/sql/oracle/ad-locales.sql:
reverting to oacs-5-2 stable

* ./packages/acs-lang/
reverting to oacs-5-2 stable

2006/06/21 gustafn

* ./packages/acs-lang/tcl/localization-procs.tcl:
fix for bug #2905

2006/06/20 gustafn

* ./packages/acs-templating/tcl/richtext-procs.tcl:
disable rich text editing for safari (fix for bug #2928)

2006/06/20 daveb

* ./packages/acs-subsite/tcl/test/acs-subsite-procs.tcl:
Add test to make sure someone did not accidentally add the
"Unregistered Visitor" to a group other than "The Public".

2006/06/16 roelc

* ./packages/acs-subsite/lib/login.tcl:
Set the email/username and password fields via css, some
versions of IE mismatch their lengths even if set via the
size attrib

2006/06/08 rocaelh

* ./packages/acs-kernel/sql/postgresql/utilities-create.sql:
fix on this no-used function that was preventing acs-kernel
to install in PG8.1.4

2006/06/07 rocaelh

* ./packages/acs-core-docs/www/aolserver4.html:
changing to @aolserver.cvs.source...

2006/06/06 gustafn

* ./packages/acs-templating/www/resources/xinha-nightly/plugins/OacsFs/lang/de.js:
* ./packages/acs-templating/www/resources/xinha-nightly/plugins/OacsFs/lang/en.js:
adding language files for OacsFs

2006/06/02 skaufman

adding missing messages

2006/05/30 victorg

Catalogs from for packages NOT
included in the OpenACS Core

2006/05/29 victorg

* ./packages/acs-templating/
Taking up the version to 5.2.3

Posted by Naveen Agnihotri on
Gustaf, You were exactly right! That patch in bootstrap.tcl fixed it!

Now there are some suspicious warning messages in the log, of the kind of:

[04/Apr/2007:05:04:30][7091.1][-main-] Warning: db_qd_get_fullname: there is no documented proc with name xo::db::has_ltree returning dbqd..NULL (declare proc xo::db::has_ltree with ad_proc to make it work with the query dispatcher
[04/Apr/2007:05:04:30][7091.1][-main-] Warning: db_qd_get_fullname: there is no documented proc with name Generic::object_type_exists returning dbqd..NULL (declare proc Generic::object_type_exists with ad_proc to make it work with the query dispatcher

Hopefully these aren't something to worry about? Thanks so much!