Forum OpenACS Q&A: Error sending email from user-new-2.tcl Expected a 250 status line; got: 501 5.0.0 Invalid domain name

Finally got it installed.  Everything is working very well for the most part.  I am getting the above error in my error log though.  It occurs if I try to add a user or anything that deals with emailing the user (for instance password reset notification).  I have tried a few different addresses to see if that was the issue.  I also directly edited the user-new-2.tcl file to see exactly which part it was failing on (since it appears to send two emails [potentially], one to user and one to admin).  It's choking on the first email.

I tried passing straight static strings into the function, but that still didn't work.  Then I set the var's directly in the script to see if it mattered.  It didn't.

I feel rather stupid asking for help, but I'm hoping someone else has run into this issue previously...  Google was of little help unfortunately.

Hopefully we can get this running 😊  We need to use it this fall as a replacement to TEAMS ( ) and currently we're "evaluating" Microsoft SharePoint.  I REALLY would prefer something else if at all possible! 😊  Thanks.

PS - We use it more for the 'team collaboration' features than actual classroom/teaching type stuff, that's why SharePoint is an option.

Is there anything interesting in your mail log?  And does outgoing mail work ok from that machine (when not sent through OpenACS)?
I had the same problem after installing OpenACS over a RedHat 8.0.

It seems that recent versions of sendmail require the exact domain name after the HELO command, but in the sendmail.tcl script (I found this in "/usr/local/aolserver/modules/tcl) there is an extraneous description, i.e. "Aolserver" preceeding the domain name.

What I did was to change the line

" _ns_smtp_send $wfp "HELO AOLserver [ns_info hostname]" $timeout"
" _ns_smtp_send $wfp "HELO [ns_info hostname]" $timeout"
and it works.
Cathy - I admit, I hadn't tested just sending normal mail outside of OpenACS/.LRN.  I guess I wasn't 100% sure "what" it was using as a mailer in the first place.

David - Sorry I didn't catch that thread before posting.  It contains the solution, as well as Claudio's post.  Thanks for your time, it's appreciated.  I try and check before I post, but didn't see that one 🤔

Claudio - Thanks so much for your reply.  That is exactly what the issue is/was.  Once I changed it (and restarted AOLServer), it works great.  I think I have almost all of my initial installation bugs worked out now for .LRN, this is a great system!

I have noticed that on the password reminder form when it asks for your name I could enter either the name for that account or the name of another account I had created (the initial admin one).  Not sure if this behavior would work for any named user yet, but it's interesting...

Thanks again everyone.