Forum OpenACS Development: new gentoo ebuilds for aolserver-4.0_beta8 and for modules

I've added updated (and tested) gentoo ebuilds to the gentoo bugzilla for now (until I bug them enough to get it into the main portage tree).






hey Chris,

this rocks, thanks alot. do you think you could post or direct me to directions of how to install ebuilds that are not in portage? i've looked in the portage manual and didn't see anything. i tried to download the ebuild directly and wasn't able to accomplish anything either.




In /etc/make.conf uncomment the line for user ebuilds. It should be /usr/local/portage or something.

Then just put the ebuilds in there in the appropriate directory structure.

Yes, specifically uncomment the
line in /etc/make.conf.

Then, ensure you have that dir and the subdirs in which to place the ebuild:
in which goes the aolserver-4.0_beta8.ebuild
The only tricky one is the nssha1 one, in which you have to make
and put in that the diff nssha1-0.1.diff
in addition to putting the ebuild in nssha1/
Often, additionally, although sometimes portage will detect ebuilds in your overlay dir from anywhere, it sometimes helps to run emerge <ebuildfilename> while in the ebuild's directory, if for some reason portage can't find your newly downloaded ebuild. Give that a shot.

Hope that helps!

Good luck!

Thanks Chris and Jon! This is really great. I once spent a whole weekend installing OACS on gentoo, what with creating the users in the right groups in the right dirs, etc. All I had to do tonight was "emerge aolserver.ebuild"!



Hey Talli! Glad it worked for you!!

On a related note, here's my suggestion for 'Install Documentation Lite' for gentoo 😉

I've added a tDOM ebuild to the Gentoo bug tracker.

There is also an OpenFTS ebuild.

For my setup I modified Chris's ebuilds, per his comments, to install into the Gentoo standard filesystem and posted them back to Gentoo tickets linked in his post above. Also here is an example config.tcl which you would need to get your OpenACS going with AOLServer installed in this way.

Forgot to mention that I added service control scripts /etc/init.d and /etc/conf.d.
Wow, thanks for picking up the ball Lee!  I understand that the default directories have changed recently in gentoo (I am in the process of upgrading both my apache and my aolserver to your latest aolserver ebuild).  I will give some feedback on my success with the new aolserver ebuild hopefully this weekend.


I've uploaded a version of the aolserver ebuild for the official 4.0 release and fixed the tDOM ebuild (DNS stopped resolving so now it downloads from

The official Gentoo maintainer assigned to these (and the tcl) ebuilds says he doesn't have enough time to keep them up to date in cvs and is currently looking for someone else to take them on...  once that happens they should appear in the main portage tree.

I would be interested in being a gentoo package maintainer, but I am not sure how to become one (I have mentioned it loosely to a few ppl in the past). I have submitted like 6+ or so packages over time to gentoo...

I think it would be great to get in the official cvs of gentoo with aolserver + modules and even openacs if possible. That was the whole point of making packages to me.

In case anyone else hadn't noticed yet, aolserver is now in the official Gentoo CVS:


The modules needed to run openacs haven't been added yet, but one thing at a time :)