Forum OpenACS Improvement Proposals (TIPs): Tip #16 (Approved): Include new package: Redirect
This is a simple package that sends a redirect to another location, depending on its parameter settings. It is intended for the situation when you moved parts of your site to another location in order to reorganise your site, but don't want old links such as users bookmarks, links from remote sites, external search engine hits etc. to break.
Mount it at the old location using the openacs site-map, and set its NewURL parameter to the new location. E.g. when you moved a tree of your site from '/some/old/path/' to '/newurl/' then mount an instance of redirect at '/some/old/path/', and set its NewURL parameter to '/newurl/'.
The package is in file-storage: http://openacs.org/storage/file?file_id=118294
I would also suggest to set the core flag to true so that it gets installed upon OpenACS installation, since it serves a general purpose that might as well be implemented in the site-map/request-processor if it wouldn't be easier like that as a package, and it is fairly lightweight (no datamodel, few files).
I was wondering how hard it would be to implement a "Move instance" feature in Site Map that does exactly what you describe above - moves the package to another URL and then mounts the redirect package at the old one.
How dos Redirect compare with the Gatekeeper package? Shouldn't those be integrated or merged? If not, then should redirect superced gatekeeper (to avoid yet another redundant, non-maintained package)?
Gatekeeper seems to do more than redirect, like forward cookies.
If Redirect is going to superceed Gatekeeper, we need some upgrade path, no?
Nevertheless gatekeeper could use some documentation.
Though I like "redirect" as a name better - I know what that does, I just don't know how much that does from the name, while "gatekeeper" doesn't tell me much.
I approve of it being added regardless, just asking a question, though I'm with Lars, let's not install by default.
I did not consider adding the functionality to the gatekeeper package, due to the misleading name. Should we merge gatekeeper into redirect? Rename gatekeeper to http-pass-through? Leave it and pursue more important issues?