Forum OpenACS Q&A: Re: macosx and no fullquery

Posted by bill kellerman on
you mean aolserver 4 and openacs may not work on os x?

i've installed the same setup on linux and freebsd without any problems.  just os x is giving me all these headaches...  i've read other people have gotten it to work, so i don't know if it's something i'm doing wrong specifically or what.

i'll try the older version though, just to see if it works.

by the way -- the docs on your site are very helpful.

Posted by Vinod Kurup on
I just installed OpenACS on AOLServer4 on my Mac, but I used OpenACS HEAD and therefore tDOM, not nsxml.

Did you restart the server after installing forums?

Posted by Jade Rubick on
I'm not totally confident about my comments on Aolserver. Perhaps you can ask on IRC?
Posted by bill kellerman on
It's not just the forums.

I chunked the installation and started over, recompiling everything to make sure there weren't any error messages I missed.  Still didn't notice anything, but when I get to the point of starting aolserver for the first time to begin the bootstrap process for openacs, the "no fullquery" message was in the log on startup.

The portion of the log where it occurs:

[17/Sep/2003:14:51:51][8701.2684358124][-main-] Notice: Loading packages/acs-tcl/tcl/xml-2-procs.tcl...
[17/Sep/2003:14:51:52][8701.2684358124][-main-] Debug: NO FULLQUERY FOR dbqd.acs-tcl.tcl.00-database-procs-postgresql.db_table_exists.table_count --> using default SQL
[17/Sep/2003:14:51:52][8701.2684358124][-main-] Notice: Querying '
        select count(*) from pg_class
        where relname = lower('apm_packages') and
            relname !~ '^pg_' and relkind = 'r';'

No other wierd messages that I haven't seen on working installations.

From that point, openacs will install through the web interface.  Once I install and enable packages, I get the other errors when going to their url's (for example, forums).

I'm trying the install with aolserver3.3ad13 just to see if I can tell a difference and what might be causing the problem.

Otherwise, I'll try opeancs head.  Thanks for the link.

Posted by bill kellerman on
oh.  for aolserver 4, there is another entry in the startup log:

17/Sep/2003:14:51:52][8701.2684358124][-main-] Debug: QD=Postload files to load: /usr/local/aolserver/web/openacs/www/index-oracle.xql /usr/local/aolserver/web/openacs/www/index-postgresql.xql /usr/local/aolserver/web/openacs/www/index.xql
[17/Sep/2003:14:51:52][8701.2684358124][-main-] Warning: Query dbqd.www.index-oracle.site_nodes has rdbms info oracle 8.1.6 which is not compatible with system rdbms postgresql 7.3

i don't know if this has anything to do with the problem?  because i don't really know what this means.

Posted by Jade Rubick on
Make sure in your config.tcl you've specified you're using Postgres. For some reason, it seems to think you're using Oracle.
Posted by bill kellerman on
Posted by Vinod Kurup on
actually, I get the complaint about the oracle/pg incompatibility as well, but it doesn't seem to break anything. I haven't investigated why it happens.

When I see the 'default SQL empty' error message, I think of a couple things:

  1. Did I restart the server after installing any new packages?
  2. Is the XQL file actually there? e.g. forums/www/index-postgresql.xql
  3. Does it contain the query in question? e.g. select_forums
  4. Is the XQL malformed in any way (missing brackets,etc)? Shouldn't be the case since you haven't edited anything.
  5. Is the XML parsing screwed up? Did ns_xml load properly, without errors?
If none of that is helpful, you might next try posting a log of your OpenACS startup somewhere so we could take a look.
Posted by Randy O'Meara on

I don't believe that the "...NO FULLQUERY ...db_table_exists.table_count..." message is an error. If I recall from perusal of my (HEAD based) error log over the weekend, there is no .xql file for that tcl page. I got the impression that it was intentional (no separate xql file, that is). It simply uses the sql defined inline. BTW, the compatibility message has been there for some time. I haven't investigated either.

If you're not seeing other problems related to the QD (query dispatcher) during the installation phase, I believe you can rule that out as the root cause of your problems.

If I were in your position, I would drop back to the supported version of aolserver and oacs, reinstall, and then pick *a* package (forums would do), and trace the steps of a single operation on that package with debug logging enabled.


Posted by bill kellerman on
Okay -- concerning oacs463...

1. I did restart the server.
2. 3. 4. Shouldn't be the any of these things as the same installation works on other os's. I'm not modifying any code.
5. I thought maybe nsxml was broken, but I ran this test from this page on and everything seemed to be working. No error log entries on nsxml.

I'm going to see how much debugging I can do and then I will post the logs.

Thanks for the help everyone.
Posted by bill kellerman on

i just tried everything one more time.  the only thing i did differently was download the newest versions of libxml2 (2.5.11) and libxslt (1.0.33) from to recompile nsxml-1.5.  after i proved it worked with the script from fifthgate, reinstalled.

everything now seems to be working as it does on any of my  installations.  i've been able to enable and mount packages with no problem.  i still get the "no fullquery" all over the logs, but i guess those are normal as it doesn't seem to have an effect.

i guess either i botched the original libxml/xslt/nsxml stuff, or there were version problems.  on a related note, i'm not sure the /tests/ files in the nsxml source work for testing.  the script above did.

thanks to everyone for your time and help.

i'm so happy that it's finally up and running, i'm going to let it sit for a while and stare at it.  but soon i'll go through the process again, write everything down, and make sure there is nothing to add to the various install on xxx platform docs.