Forum OpenACS Q&A: Upload Portrait Issues

Posted by Nathan Reeves on
Just finished installing B3 and attempted to upload a portrait.  Was
able to select a picture from my local drive, trying to upload it
causes and error to be output to the web browser.

Also get error messages in the server log file about files being
invoked from within.

Tried the same exercise on openacs (upload a portrait) and all works

Any ideas?



Posted by Roberto Mello on
I don't think I am understanding... You installed B3 (Beta 3 ? Of what ? OpenACS, PostgreSQL ?) and uploading portrait didn't work.

Then you installed OpenACS and everything worked. OpenACS == ACS/pg. OpenACS is the new (and catchy) name for ACS/pg. I don't see what problem you are having. Can you be more specific and give us more details please ?

Posted by Ben Adida on
I'm guessing what you mean is that you tried it on the OpenACS web site and it worked? A snippet from your error log would help, but I'm guessing that you don't have the latest and greatest driver compiled for ACS use. Which version of AOLserver are you using? Have you compiled the Postgres driver with the right flags for acs use?

Speaking of which, I should release the newest version of our driver, I think it's behind schedule...

Posted by Nathan Reeves on
Okay.  Apologies for complete lack of reference with the B3.

That was supposed to be OpenACS B3.  

I've just updated the postgres driver and the image upload works
great now. My fault on this one. I had used an older version of
the postgres driver.

Next problem I face at the moment is trying to create a release in
the SDM. I can enter the details of the release, the user
search brings up the correct email address but once I pick the
email address I get the error "Database operation "dml" failed.

Checking the server error log shows the following [02/May/2000:08:51:51][2256.6148][-conn2-] Notice: var: package_id [02/May/2000:08:51:51][2256.6148][-conn2-] Notice: var: release_id [02/May/2000:08:51:51][2256.6148][-conn2-] Notice: var: major_version [02/May/2000:08:51:51][2256.6148][-conn2-] Notice: var: minor_version [02/May/2000:08:51:51][2256.6148][-conn2-] Notice: var: patch_version [02/May/2000:08:51:51][2256.6148][-conn2-] Notice: var: beta_version [02/May/2000:08:51:51][2256.6148][-conn2-] Notice: var: supported_platforms [02/May/2000:08:51:51][2256.6148][-conn2-] Notice: var: unsupported_platforms [02/May/2000:08:51:51][2256.6148][-conn2-] Notice: var: general_description [02/May/2000:08:51:51][2256.6148][-conn2-] Notice: var: user_id_from_search [02/May/2000:08:51:51][2256.6148][-conn2-] Notice: var: first_names_from_search [02/May/2000:08:51:51][2256.6148][-conn2-] Notice: var: last_name_from_search [02/May/2000:08:51:51][2256.6148][-conn2-] Notice: var: email_from_search [02/May/2000:08:51:52][2256.6148][-conn2-] Error: Ns_PgExec: result status: 7 message: ERROR: parser: parse error at or near "," I'm checking /www/sdm/pvt/package-add-new-2.tcl but can't see where the error is. Any ideas? Thanks for the help
Posted by Don Baccus on
OK, you have some sort of SQL error, as Ns_PgExec is pointing out.  What you need to do now is turn on the "LogSqlErrors" parameter in your database pools (in your initialization file).  The driver will then log the actual SQL query that's failing.  Then you can post it here, and we can take a look.