Forum OpenACS Q&A: Re: compiling nspostgres

13: Re: compiling nspostgres (response to 1)
Posted by Michael Cordova on
I'm trying to install OpenACS 5.4 with AOLserver 4.5 on Mac OS X 10.5 (Leopard). The mac doc is a bit outdated on I'm following the guide.

When compiling nspostgres (and after fixing some other bugs, like -lnsdb flag),
/usr/local/src/aolserver45/nspostgres# make POSTGRES=$PG ACS=1 NSHOME=${NS}
I'm getting that error:

ar rv libnspostgres.a
ar: no archive members specified
usage:  ar -d [-TLsv] archive file ...
        ar -m [-TLsv] archive file ...
        ar -m [-abiTLsv] position archive file ...
        ar -p [-TLsv] archive [file ...]
        ar -q [-cTLsv] archive file ...
        ar -r [-cuTLsv] archive file ...
        ar -r [-abciuTLsv] position archive file ...
        ar -t [-TLsv] archive [file ...]
        ar -x [-ouTLsv] archive [file ...]
make: *** [libnspostgres.a] Error 1

I've also tried:
/usr/local/src/aolserver45/nspostgres# make install POSTGRES=$PG ACS=1 AOLSERVER=/usr/local/aolserver

/usr/local/aolserver/bin/tclsh8.4 /usr/local/aolserver/bin/nsinstall.tcl -d /usr/local/aolserver/bin -e
installed: /usr/local/aolserver45/bin/ (0755)
/usr/local/aolserver/bin/tclsh8.4 /usr/local/aolserver/bin/nsinstall.tcl -d /usr/local/aolserver/lib -e libnspostgres.dylib
installed: /usr/local/aolserver45/lib/libnspostgres.dylib (0755)
/usr/local/aolserver/bin/tclsh8.4 /usr/local/aolserver/bin/nsinstall.tcl -d /usr/local/aolserver/lib libnspostgres.a
ranlib /usr/local/aolserver/lib/libnspostgres.a
ranlib: can't open file: /usr/local/aolserver/lib/libnspostgres.a (No such file or directory)
make: *** [install-dll] Error 1

But can't fix that.

14: Re: compiling nspostgres (response to 13)
Posted by Michael Cordova on
/usr/local/src/aolserver45/nspostgres# make install POSTGRES=$PG ACS=1 INST=/usr/local/aolserver
I get that error:
/usr/local/aolserver -d /usr/local/aolserver/bin -e
make: execvp: /usr/local/aolserver: Permission denied
make: *** [install-mod] Error 127
Even after doing /usr/local/src/aolserver45/nspostgres# chmod -R +w /usr/local/aolserver I get the same error.

I feel completely lost.

Posted by Raúl Morales Hidalgo on
ar options in OS X are with a dash "-" I guess you'll have to correct that in your Makefile
Posted by Cesareo Garci­a Rodicio on
This is old but to ease problems with PG building.

Now I'm on Mac OS X Mountain Lion and nspostgres from Aolserver git.

I don't know how to solve this errors BUT a solution that worked for me is:
- Don't forget to add -lnsdb in Makefile
- Do make file (set ACS and POSGTGRES approprieately)
- You will get these errors
- Forget that and copy that, that it has been created in that directory, in aolserver/bin

And it works!