Forum OpenACS Q&A: Acs mail lite 0.2a doesn't seem to work

I'm not sure if other people are having these problems or not, but upon upgrading to acs-mail-lite 0.2a, packages using acs-mail-lite are not sending out messages.

Christof is having this problem too, but with forums.

Here's what I see in my error log:

[07/Jun/2004:18:08:05][19270.4101][-conn:ibr::1] Notice: acs_mail_lite::deliver_mail successful
[07/Jun/2004:18:08:12][19270.3076][-conn:ibr::0] Notice: acs-mail-lite: Email bouncing from, mail not sent and deleted from queue
[07/Jun/2004:18:08:12][19270.3076][-conn:ibr::0] Notice: acs_mail_lite::deliver_mail successful

Testing from developer support with this:

acs_mail_lite::send -to_addr "" -from_addr -subject "test please ignore" -body [db_string get_time "select current_timestamp" -default "none"]
Yields that error.

I have verified that the SendmailBin path is correct (/usr/sbin/sendmail, and have tried with both that and SMTP.

Any ideas on how to fix this? I need to have it working before people start getting back on the intranet tomorrow morning.

Posted by Jade Rubick on
It looks like Jeff fixed this two months ago.

The problem was that I upgraded using the openacs-5-1-compat tag instead of oacs-5-1. My understanding was packages should be tagged with openacs-5-1-compat, but it appears that's not always the case.

It appears the functionality is busted on the openacs-5-1-compat 'branch', so I'm going to tag it, since the changes seem very minor. I'm also going to bump the package to 0.21a, so that existing installs can upgrade via the package repository.

Posted by Christof Spitz on
Jade, as I wrote in my posting, I took the latest acs-mail-lite from cvs, and the error has gone.

But I am still having the problem that no mails are send to the site admin (namely myself). Today I also installed the latest dotlrn. Sending mails to "normal" users work, but not to the admin.

Posted by Malte Sussdorff on
After a chat on IRC i realized, that submissions to oacs-5-1 are not automatically tagged as openacs-5-1-compat. As long as this is not done, you should stick with the oacs-5-1 cvs checkout and only use openacs-5-1-compat for packages that are not on that branch but are reported to work with 5.1
Posted by Christof Spitz on
Sorry, I am rather ignorant, but I try to learn. Thanks for any help to make me understand.

I installed the latest .LRN which probably runs on OpenACS 5.0.x The package manager says acs-mail-lite is version 0.1d.

Since acs-mail-lite doesn't send notifications to me as the admin (but to other users), I tried to update to the latest version from cvs which is 0.21a according to

stopped aolserver
cd packages
mv acs-mail-lite ~/backup/acs-mail-lite.01d
cvs -z3 -d checkout acs-mail-lite
restarted aolserver

When I look at the package in the package manager, it still reports acs-mail-lite as version 0.1d, although it can't see the older directory any more.

Why is the older version reported?

P.S. After trying I learned that the acs-mail-lite 0.21a doesnt work with .LRN 2.0 at all, so I had to come back to 0.1d. Still curious why the older version was reported from apm after the "upgrade".

And still have the same problem that no mails that are handled by acs-mail-lite are send to the admin. Who knows why?

Posted by Jade Rubick on
Christof, after changing the files in the file-system, you have to upgrade them from the administrative UI. There are two places for this, the Install link under Administration, and the APM (the package manager).