Forum OpenACS Q&A: feedreader

Posted by Ben Koot on
Hi folks,

I am using the latest feedreader package, but it looks like it's broken. Subscrbing freqently updated sites like scriptingnews, never give any updates. Is there somewthing I need to change in the default package to make it work?


2: Re: feedreader (response to 1)
Posted by Luis Garcia on

I was about to ask the same question since I have entered several addresses for news feeds and none of them work. I though I was doing something wrong; but I guess there is a problem then.

3: Re: feedreader (response to 1)
Posted by Ben Koot on
4: Re: feedreader (response to 1)
Posted by Guan Yang on
I'll try to take a look this weekend.
5: Re: feedreader (response to 1)
Posted by Ben Koot on
thanks Guan


6: Re: feedreader (response to 1)
Posted by Thomas Rathjen on
I get the updates of the subscribtions since I have deleted the command 'ds_comment "test"' in the file source-procs.tcl.


7: Re: feedreader (response to 1)
Posted by Esti Alvarez on
From the logs, I get this message for subscription to new feeds:

 Notice: Error parsing RSS feed: invalid command name "na_get_elements"

I've tried copying the procedure from an older version, this is the source:

ad_proc -public na_get_elements {
 } {
     set matches [list]
     foreach node_id $nodes {
         if { [string equal $match [xml_node_get_name $node_id]] } {
             lappend matches $node_id
         } else {
             #set children [ns_xml node children $node_id]
             set children [xml_node_get_children $node_id]
             if { [llength $children] > 0 } {
                 set matches [concat $matches [na_get_elements $children $match]]
     return $matches

But then I get:

invalid switch: "-no_format"
    while executing
    (procedure "string_truncate" line 1)
    invoked from within
"string_truncate -len 245 -no_format -- [lindex $channel 0]"
    (procedure "na_add_source" line 7)
    invoked from within
"na_add_source $feed_url $user_id $package_id :key"

I'm probably using an older version of acs-tcl package (string_truncate is defined in that package), but news-aggregator didn't ask me to upgrade when installing it. I think should have some information of what version of acs-tcl it requires.

8: Re: feedreader (response to 1)
Posted by Guan Yang on
Simon had a quick look. Part of the problem is that I haven't worked on news-aggregator + feed-parser for 6 months. (news-aggregator is the UI, feed-parser is the RSS parser that returns a Tcl array data structure from RSS.)

The very newest code for news-aggregator is in HEAD. There's a tag, news-aggregator-0-9d, and a handful of fixes after -0-9d. However, this version was never mergerd to oacs-5-1; I think version 0.4d is in oacs-5-1, which is most likely broken.

If anyone is interested in working on this code, feel free to contact me (here, email, irc, aim or Skype) and I can explain the intricacies and what's broken most.

9: Re: feedreader (response to 1)
Posted by Jade Rubick on
Guan: can I ask a favor of you? Would you mind writing out exactly what the problem is in a bug-tracker bug? That way, if anyone wants to fix it, they can.

Also, if you could tag the code from HEAD with openacs-5-1-compat, then at least people will be downloading the right version, even if it is currently broken.

10: Re: Re: feedreader (response to 9)
Posted by Orzenil Silva Junior on

I am using news-aggregator from oacs-5-1 and i dont see any problem on this code at least with postgresql. The only bug i found i put into bug-tracker here

This bug is exactly the same as reported here by Esti Alvarez. The patch was applied and commited to cvs into openacs-5-1 and oacs-5-1 so i think news-aggregator in this tags will work well.

As i could see news-aggregator from HEAD seems a very modified version of the previous 5-1 branch. Maybe Guan coud talk about improvements in this new version. I appreciate very much news-aggregator and will love help on its future development.