Forum OpenACS Q&A: sec_read_security_info Error when upgrading

Request notifications

I am having a problem upgrading to a new version of AOLServer. We were using
AOLServer 3.3.1+ad13 with Postgres 7.2.3. (then acornhosting.net closed down)
I am now upgrading to AOLServer 3.4.2 using Postgres 8.0.3
Postgres works fine I can import the old data no problem.
But when I run AOLServer it starts and runs correctly.
I can telnet into port 80.
However if I try to use lynx browser to connect I get an error (see below).

I have read about this error and I have tried the modification to the security.sql file changing v_time to varchar it didn't work. I got exactly the same error.
Can anyone please help.

Error Message

Error: Filter sec_read_security_info returned error #1: syntax error in expression " ![string compare [string tolower [ns_set key $headers $i]] "
Error: tclop: invalid return code from filter proc 'Critical filter sec_read_security_info failed.': must be filter_ok, filter_return, or filter_break

To see the posts I have read look at these posts.

http://openacs.org/forums/message-view?message_id=29185
http://openacs.org/forums/message-view?message_id=80250

Collapse
Posted by Andrew Piskorski on
Why are you "upgrading" to AOLserver 3.4.2 ? That version is extremely old, and is not and never was supported by OpenACS. Unless you have some sort of unusual special requirements you haven't mentioned, you should be using the latest AOLserver 4.0.x release, currently 4.0.10. You want the latest Tcl as well - 8.4.12 was just released a few days ago.

You might actually want to use the latest on the AOLserver 4.x branch from CVS, as if I remember correctly, some DNS related bugs introduced just before and then fixed after the release of 4.0.10, but they don't matter for many people anyway, so you might as well try 4.0.10 first.

Collapse
Posted by Torben Brosten on
Also, you might want to look at this compatibility chart:

http://openacs.org/doc/current/individual-programs.html

to verify that the Postgres version is compatible with the version of OpenACS you are using.