Forum OpenACS Q&A: Hiding the port 8000 to appear from URL when logging in

Request notifications

Ok I have a clean install of OpenACS on a Ubuntu server on my lan.The IP of this machine is 192.168.1.5 and any one within my LAN can access http://192.168.1.5:8000 I have disable port 80 on this machine as apache is running. To do so in /etc/default/aolserver4 RUN_DAEMON=no and /etc/aolserver4/conf.d/openacs.sh AOL_ADDRESS=192.168.1.5 Now there is another computer on our LAN which basically has a public IP and I want an Apache reverse proxy here for OpenACS. This is also correctly working the Apache vhost configuration on this machine is <VirtualHost *:80 > ServerName openacs.openitup.in ServerAdmin webmaster@localhost ProxyRequests off <Proxy *> Order deny,allow Allow from all </Proxy *> ProxyPreserveHost On ProxyPass / http://192.168.1.15:8000/ ProxyPassReverse / http://192.168.1.15:8000/ </VirtualHost *:80 > Now http://openacs.opentiup.in is visible on internet but the moment some one logs in the URL changes to http://openacs.openitup.in:8000 I do not want this to happen since on Gateway (where Apache is) port 8000 is not open. So how can I stop this URL from automatically changing in the above scenario?
Hi James,

Refer to my earlier posts to you: http://openacs.org/forums/message-view?message_id=3580626#3584663

In order to get this working, you're going to have to upgrade OpenACS to a newer version that has a working version of SuppressHttpPort parameter.

or..

grab the related code from Head version of these two files:

packages/acs-tcl/tcl/utilities-procs.tcl
packages/acs-tcl/tcl/security-procs.tcl

cheers,

Torben

Hi Torben let me know where can I get the code of these two lines and what should I do with them.
I checked 5.5.1-2 is the version I am using on Lucid.
Hi James,

On the Home page of OpenACS, there's a link to download OpenACS 5.6.0

The easiest thing to do would be to update to this version, to be sure to get all the changes.

cheers,

Torben