Forum .LRN Q&A: admin portals not being displayed correctly plus fix

The admin portals are not being displayed correctly on current CVS code. By default, the admin portals are being displayed with -render_style all_in_one. From a quick glance, the render-element.adp file in /packages/new-portal/www/render_styles/all_in_one missed passing the @element.resource_dir@ property. So temporary fix is to add the line:

<property name="dir">@element.resource_dir@</property>
Ouch. I made a blooper on the above post. I was looking at a stale code of mine. Scrap the property tag fix. My temporary fix was to get rid of the -render_style param passed in dotlrn::render page in /packages/dotlrn/www/one-community-admin.tcl. I apologize for my erratic previous post.
deds: could you describe what problem behavior you are seeing here?

Before I removed the -render_style param from the call to dotlrn::render_page in /dotlrn/www/one-community-admin.tcl, whenever I click on "control panel", everything is displayed but without the template applied.  This means that I see them as plain text, without the borders, colors and the shade and hide icons.  When I removed the -render_style parameter, then the correct template is now being displayed.

I don't know if anyone else experiences this, but it happens on 3 separate installations here at the office.  It was already like this since I started with my first install a couple of months ago and it just made me wonder a couple of days ago when I tried http://myserver/portal/admin on my server and I can see a different look for the "class_pretty_name Administration Portal" for all classes/clubs.


I've got the same problem, not only in the community control panel, in the class and user control panel too. I have installed dotLRN this week (friday).

I've applied your patch and now it works fine.

that's not a bug, that's a feature! :)

That's what render-style "all-in-one" is supposed to do. It's
a way to have a portal masquerade as a regular page by removing the decoration around each portal element.


Now I get it. I didn't look at the code that much to trace that it was a feature. =) I assumed it was a bug because http://myserver/portal/admin shows them differently. Thanks.

Actually, deds, that was me. I was turning off some bouncing email alerts, and obviously forgot to logout. My apologies to both you and Tim.