Forum OpenACS Q&A: Re: When building nsopenssl-2.1a I get the "OpenSSL was not compiled with thread support!" error

Hi Gustaf,

I'm running ACS-3.4.9, and for a while I've been getting the nsopenssl errors mentioned above. So I took the task of recompiling AOLserver-3.3.1+ad13 to see if the errors disappeared.

I now believe the errors occur because OpenSSL is not compiled with thread support on the box. The person that originally installed everything on the box didn't compile the AOLserver, he just copied the executables, so he had no way of knowing what was going on.

We have a lot of in house code written for this ACS system and migrating to OpenACS would be HARD work (http://openacs.org/forums/message-view?message_id=250524). I'll probably end up doing this some day.

Before posting to the AOLserver mailing list I'll try running ACS 3 on AOLserver 4. I have not tried this because of the ad13 part in AOLserver-3.3.1+ad13 but who knows, maybe I'll be extremely lucky and get it working =). If you know this just won't work, please let me know.

Thanks!

Pedro

Collapse
Posted by Andrew Piskorski on
Ah, so you work with Eve, Pedro?

Using AOLserver 4.0.x or 4.5.x will probably work for ACS 3.4.9, but you might have to tweak a few things. AFAIK, all the ad13 features that you should need to run ACS were eventually forward-ported to AOLserver 4.0.x. I don't know whether they kept the exact same API or not in all cases though, particularly for the character set stuff.

I don't think 4.0.x includes the ad13 Tcl bytecode cache, which might be a performance issue if your site is very busy. Then again, some very large sites (like Gustaf's) are running on OpenACS + AOLserver 4.x, and they don't seem to have missed it.

Collapse
Posted by Pedro Liska on
Thanks for your help Andrew. I'll try this out as soon as I get a chance.

Pedro

PS: I do work with Eve, she's awesome. I see you also worked with her in the ArsDigita times =)