Forum OpenACS Q&A: Where are promised 5.3 Packages?

Request notifications

Posted by Renny Curvers on
I tried to install but got the next two messages using my URL

Message #1:
OpenACS Installation: Welcome
Thank you for installing the Open Architecture Community System (OpenACS), a suite of fully-integrated enterprise-class solutions for collaborative commerce. This is the OpenACS Installer which performs all the steps necessary to get the OpenACS Community System running on your server.

Please read the Release Notes before proceeding to better understand what is contained in this release.

Your PostgreSQL driver is correctly installed and configured.

The OpenACS data model is already installed. Click Next to scan the available packages.

Message: #2
Proxy Error
The proxy server received an invalid response from an upstream server.

The proxy server could not handle the request GET /packages-install.

Reason: Document contains no data

Apache/1.3.37 Server at Port 80

Also restarting AOL Server seems not to solve anything.

Could it be that no packages are attached to OpenACS 5.3?

Your assistance is well appreciated.

Many thanks!
Renny Curvers

Posted by Brian Fenton on
Hi Renny,

I'm not aware of what's happening with 5.3 but I can see that your error is caused because you are connecting to an Apache server when you probably want to be connecting to AOLserver:
"Apache/1.3.37 Server at Port 8"

What IP address and port is AOLserver running on?


Posted by Renny Curvers on
Hello Brian,

The IP address is Port 80.

We did a clean install of OACS 5.3 on IP: on port 80, but still get the same error message: Proxy server received an invalid response from an upstream server.

The proxy server could not handle the request GET/packages-install.

Reason: Document contains no data.


Posted by Brian Fenton on
Hi Renny,

If I go to in my browser it tells me that you're running Apache/1.3.37 Server. It should say AOLserver.

What do you get if you run this on the Linux command line?
netstat -natp | grep ':80.*LISTEN'


5: Mystery error .... (response to 4)
Posted by Ben Koot on
The problem still exist. Both Renny's and my site are a hub hosted Premium Plan. It is on a virtual machine using aolserver (with apache reverse proxy). It has always worked like a charm, but 5.3 doesn't seem to accept this. I really hope one your geniouses can help us out.

I have been googleing for this problem and strangely a lot of people seem to have this problem since 1998 on many different systems, but nobody ever seems to be able to come up with a solution.


6: Re: Mystery error .... (response to 5)
Posted by Matthew Dodwell on
Just checking the usual basics - have you got the aolserver script to pre-bind to port 80 (-b flag). I need to do this for's servers, else I get their default apache page.


Posted by Torben Brosten on

Ben, when I bypass the apache reverse-proxy on that site, I get this browser error:

"Too many redirects occurred trying to open “...”. This might occur if you open a page that is redirected to open another page which then is redirected to open the original page."

It seems there is a misconfiguration in aolserver/openacs somewhere. Make sure that all references to the domain name in the aolserver and openacs kernel parameters are consistent.. either using or not using the prefix "www.".

Once you have the site working on the port served by aolserver, then any reverseproxy issues can be addressed.

8: Re: Mystery error .... (response to 5)
Posted by Marc Fournier on
Yes, we setup all our startup scripts to pre-bind ... I've even done it for ports about 1024, so that its 'habit' vs something to remember ...

'k, let's see if I can add some to this thread though ...

If I go to the web site, I get the 'Welcome' page, and a button for 'Next>' ... if you click on Next, it comes back with a 'Document contains no data' error with the URL for /package-install?

... looking in the OpenACS logs, there is:

[11/Feb/2007:20:02:46][99046.135123968][-conn:11-] Error: Unable to source /usr/local/www/ file does not exist.
[11/Feb/2007:20:04:47][99046.135123968][-conn:11-] Notice: exiting: timeout waiting for connection

checking the file system, there is no package-install.tcl file in that directory, only an 'install.tcl':

villagetalk# ls /usr/local/www/
index.tcl install.tcl

so, is it referencing the wrong file, or is the file mis-named? is it safe to rename install.tcl -> package-install.tcl?

Posted by Torben Brosten on
Posted by Marc Fournier on
Ben, database reloaded with changes that Torben pointed to above applied ... you need to re-fill in the various fields again though ...

Torben, can the scripts not try and detect if appropriate settings are made and error/warning accordingly? Ie:

# show default_with_oids;
(1 row)

if off, then error saying that this needs to be fixed before it can load the schema?

Posted by Torben Brosten on
Marc, yes, having useful error messages is especially important during install/startup. Perhaps one of the kernel developers will add the feature.

If not, I'll see about adding it in the next couple of weeks. Here's the doc on the bootstrap process (as a reminder for me) or in case someone wants to start at it before me ;)