Forum OpenACS Q&A: tDOM install on debian, cannot find tcl config defs

Am attempting an Openacs5 install on debian woody(stable).

I've uncommented the 3 lines relating to the unix/CONFIG aolserver 4 installation. Then:

thing2:/usr/local/src/tdom/unix# sh CONFIG
loading cache ./config.cache
checking for memmove... yes
checking for bcopy... yes
checking for correct TEA configuration... ok
checking for Tcl configuration... configure: warning: Cannot find Tcl configuration definitions

am using tcl8.3.3-7 installed via "apt-get install"

As a side note, the README file states:

NOTE: Be sure to have the CC=gcc defined if you're using GCC.

whereas the instructions in the unix/CONFIG file states:

# Comment-out next line if building with GCC compiler.
# CC=gcc; export CC

I've tried both ways without any change.

any suggestions much appreciated


Posted by Torben Brosten on
Okay, found the extra parameter to add in CONFIG from the openacs 5 install docs for aolserver[1]. According to the wording on the "Unix-like system and supporting software" page[2], I thought tDOM was expected to be installed before continuing.. (glad to have found it!)


Posted by Andrei Popov on
Your is not in the expected (by tDOM) location.  Check where it is with dpkg -L tcl8.3.3-7 | grep tclConfig and then specify it with configure --with-tcl=<path to>.  See my post about building on FreeBSD -- very similar situation there.
Posted by Torben Brosten on

for the record, changed:




to find

Posted by Torben Brosten on
Hi Andrei,

Didn't see your post 'til just now.

Thank you. Will try FreeBSD install next time around.



Posted by Tom Jackson on

I had trouble understanding why tDOM is installed the way it is: the script you use is just a shell script which configures, etc. If you put things in a different location, it messes up.

I have a listing of the commands needed to install tDOM on Linux. Just look at the config script they want you to run and run the commands yourself with the correct options. to configure, noting the ../configure instead of ./configure.

Torben, you are using the wrong version of Tcl. AFAIK AOLserver 4.0 requires Tcl 8.4.x, built with threads, is not supposed to work at all with Tcl 8.3.x, and certainly is not supposed to work with a Tcl 8.3.x that hasn't been built with threads support!

I don't think this has anything to do with your current problem, but you are asking for trouble trying to use the Tcl 8.3.3-7 from Debian 3.0 with AOLserver 4.0. Install the latest Tcl 8.4.x instead.

Posted by Torben Brosten on
Thanks for catching that, Andrew.

Me looking for trouble?

Trouble has already found me!  =)

Posted by Torben Brosten on
For the record, confirms tcl 8.4.x required for aolserver 4.0.

To clarify my above tdom doc dilemma:
to comment or not CC=gcc?

With threaded tcl8.4.5 installed, line should be

 CC=gcc; export CC


# CC=gcc; export CC