Forum OpenACS Development: Installing 4.x from scratch

Posted by R. Joseph Wright on
Has anyone installed 4.x from scratch yet (not updating from 3.x)? Here's where it chokes on me:
[21/May/2001:12:28:59][34475.138534912][-conn0-] Notice: ----------
[21/May/2001:12:28:59][34475.138534912][-conn0-] Notice:         0
[21/May/2001:12:28:59][34475.138534912][-conn0-] Notice: (1 row)
[21/May/2001:12:29:00][34475.138534912][-conn0-] Notice: DROP
[21/May/2001:12:29:00][34475.138534912][-conn0-] Error: Error sourcing 
error reading "file6": interrupted system call
    while executing
"gets $fp line"
    (procedure "db_source_sql_file" line 19)
    invoked from within
"db_source_sql_file -callback apm_ns_write_callback "acs-kernel-create.sql""
line 31)
    invoked from within
"source $__file "
This happens while loading the kernel data (after hitting the first "next").
Posted by Don Baccus on
I've done it a lot, but it has been three-four days so something could've broken in the meantime.

For some reason PSQL quit on you, that's what it looks like to me.  The "gets $fp line" call is in a loop that is slurping output from PSQL looking for errors.  "file6" is the name of the file handle "$fp".  Now, the question is, why did it die at that point?

Your post makes it clear that some of the datamodel is loading, how many "create" and similar things were done before it crapped out on you?

We've been having a hard time getting db_source_sql_file to work as well as we'd like (Pascal and I have both whacked at it) because PSQL has this very annoying habit of dumping all output on stderr rather than just errors.

Posted by R. Joseph Wright on
Your post makes it clear that some of the datamodel is loading, how many "create" and similar things were done before it crapped out on you?

It does 674 according to my count.

Posted by Don Baccus on
Wow, that's an exact count :)

It sounds like it is probably getting done and that for some reason the gets not stopping but overruning and causing an error.  Weird.  It's supposed to return 0 when done, but maybe it needs a "catch" too.

What platform are you running on?

Posted by R. Joseph Wright on
Ah, I probably should have mentioned that earlier.  I'm running on FreeBSD 4.3.
Posted by Don Baccus on
There are known problems with AOLserver and at least one *BSD, don't remember if it was FreeBSD or not.

Indeed, IIRC the problem was with "exec".  I can't remember if anyone figured out a way around this or not.  You might give our totally inadequate bboard search function a try with "exec" and "freebsd" as keywords.

Posted by Domingo Alvarez duarte on
Well I've tried to reisntall today and all worked fine installing
openacs4 base system.

When I tried to install aditional packages I've got some errors,
I've done some corrections on acs-messaging and general-comments
and discover that in acs-create was left the "default_context"
in the postgresql port.

I did the corrections and it works fine now, at least the installation
goes till the end.

Except for static-pages, wap, ldap and other because version.

PS.: Going through the correction proccess I discovered that not
all of us is using a start transaction at the begning of each
sql file, I did it in some of then that I worked on and that make
a lot easier to correct problems because till we correct all the
big mistakes we don't need restart the installation from zero
because the when the errors are detected by the installation
proccess part of the package was installed and making impossible
restart the proccess again.
Please let's think on it !

I've installed the code with my corrections in my cvsserver at:

If someone want's can access it with "anonymous" username.

cvs -d checkout openacs4/packages/acs-messaging

cvs -d checkout openacs4/packages/general-comments

cvs -d checkout openacs4/packages/acs-kernel/sql/postgresql/acs-create.sql

Posted by Don Baccus on
What does it take to convince you to either submit patches to the SDM with an e-mail note to the package owner, or just e-mail corrections to the package owner?

We've already explained why we don't want a separate CVS tree here at

Here is a prediction: if you don't play with the team the team will just ignore your fixes.

You seem to have the opinion that you get to dictate just how you'll help the group.  "Here, I will help, but only if I can help the way I want to work rather than the way the group works together".

You can find package owners by reading the status file at

You can find the SDM at

Posted by R. Joseph Wright on
I did some research on the "exec" problem and found an OpenBSD patch at With it I was able to get all the way through loading the kernel data model. Immediately afterwards, however, nsd dies. This is the last message:

[22/May/2001:19:00:05][51088.139350016][-conn0-] Notice: Ns_PgExec: Trying to reopen database connection
[22/May/2001:19:00:05][51088.139350016][-conn0-] Notice: Opening openacs
on localhost
[22/May/2001:19:00:06][51088.139350016][-conn0-] Error: Ns_PgOpenDb(postgres):  Could not connect to localhost::openacs:  The Data Base System is
starting up
[22/May/2001:19:00:06][51088.139350016][-conn0-] Notice: Ns_PgExec: In transaction, conn died, error returned
[22/May/2001:19:00:06][51088.139350016][-conn0-] Error: dbinit: error(localhost::openacs,pqReadData() -- backend closed the channel unexpectedly.
        This probably means the backend terminated abnormally
        before or while processing the request.
): '
        select apm_package_version__add_file(
Posted by Don Baccus on
Make sure that MaxIdle and MaxOpen in your database pools are set to 1000000000 (officially known as "a long time").

There are threading problems in Linux, perhaps in BSD as well.  (this gross step isn't necessary under Solaris, HP-UX, etc)

I'm just guessing here ...