Forum OpenACS Q&A: setting up my machine to serve pages

I've just set up OpenAcs, Aol Server, PostgreSQL on a machine
running Mandrake 8.1
Everything works fine when using the localhost settings
Now I want to make the pages accessible from outside.
I am in a bit of a confusion on how to this properly.
when i type as root: ip address, I get this:


1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet brd scope host lo

2: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP> mtu 1500 qdisc pfifo_fast
qlen 3
    inet peer scope global ppp0


Basically for now, I will be happy to get the index page, by typing
the ip address in the browser.

is my ip address ?
I've tried to replace the in my nsd.tcl file, but it
hasn't worked.
Can you help?


Posted by Pavel Boghita on
I managed to get it working in apache, but not with aolserver.
3: update on above (response to 1)
Posted by Pavel Boghita on
I have managed to get aolserver to serve pages on When I type this it automatically goes to So far so good... by the book.
The domain name I have is registered with a company in
UK,, which does email and web forwarding. At the moment
the web is forwarded to

New problem is that pages, cannot be seen outside the local machine
it typing http://[some ip address], .
Also does anyone know what shall I do, so that queries for, point to to my local machine? So, although I am not
sure how to expres this, how do I set my machine to be the host for
my domain.... is that right?

Thnaks for any replies,

Posted by Antonio Laterza on
in nsd.tcl
set hostname 'your public domain name'
set address 'your public ip address'
you have to ensure that nslook up 'your public domain name' return 'your public ip address'
Posted by Antonio Laterza on
You have more alternative:

If you have a dynamic ip address then is better to use the services provided by:

If you have a static ip address then you can/should manage the DNS entry, using free services from and adding information in 'whois' database about your new DNS.
I hope this can help you.
Posted by Pavel Boghita on
Thanks Antonio.
I really want to get the pages on my local machine seen outside, when typing the ip address. I think I need to understand how this works, before I can worry about the name translation issue (and yes, I have looked through other threads on this issue... the ones that appear in my searches anyway..😉

Ok, my ip address today is - I am at work away from local machine -  tried to ping it from work, it timed out.
When typing it times out, but the entry transforms itself to Does this mean that the request reaches the server ? Why can't I see anything then in the browser?

my nsd.tcl setting are

set hostname

set address      my ip address

Is there a problem because I use the port 8000?... should I be using port 80?

Also when I have tried nslookup for my hostname it times out, but I guess this could be a different issue than the one that occupies me at the moment... accessing my test page, by typing the ip address.

Posted by Pavel Boghita on
sorry ip address... is still the same ...
Posted by Antonio Laterza on
try to comment:
#set hostname
and restart nsd
Posted by Antonio Laterza on
then you should use that name :)
Posted by Pavel Boghita on
Thanks Antonio,

I am not sure what that really means... the reply to nslookup.
Still I have modified the setting in nsd.tcl file from port 8000 to
port 80.
On my browser on my local machine everything works well... I am
waiting to find out from a friend when he gets the time to check
both and
I am a bit in the dark of how all this naming and ip-ing works...
but I start to understand some of it.
I found a site that - you can put your
domain on their name servers, which I've listed in my DNS look-up
records... I shall know in a few days how all this works (while my
current provider also updates their records...that I moved from
their name servers...)
Anyway at least I can now play quite well with the modules on my
local machine and start learning stuff.

Thanks Antonio for your help

Posted by Pavel Boghita on
"The requested URL could not be retrieved
while trying to retrieve the URL: "

this is what I am getting on an external machine when putting
http://[my_ip_address]:8000 in the browser. (which means that the
address is resolved ...isn't it?)

(Again all works well in my local machine....connection wise)

I've set up as my hostname+domain name in my
local machine.
Also is pointing to my [ip address] in etc/hosts

Is there some security setting in aolserver that doesn't allow
anyone from outside to see the pages served? My nsd.tcl is exactly
the default one, unmodified following the rpm installation.

I have tried running apache (while stopping aolserver and postgre),
and that works fine on external machines, which leads me to believe
is a aolserver config issue.....pls, help...;)


Posted by Antonio Laterza on
ok Paul, To be visible on internet you have to:
  • use your external address:(, you can see this using ifconfig)
  • using nslookup must be related to
For example yesterday situation would work with follow setting:
set hostname
set address
To test if your configuration work, you can try:
  • telnet 8000
where 8000 is your port.
If that works, than you must wait the DNS name propagation.
Posted by Pavel Boghita on
Thanks Antonio, but how come this is not a problem in Apache
?...i.e. can see  when apache is
running? where is the localhost + domain name
as set up on the local machine.
Posted by Antonio Laterza on
I don't know why, probably apache run on all interfaces and use your /etc/hosts and /etc/resolv.conf
Posted by Pavel Boghita on
well, it does work with the hostname set to the output for nslookup I am at work now and I can see
Thanks for your help Antonio.... I am still baffled by why in apache people could use and see the index page.... but I shall consider this to be a secondary problem for now. I'll probably return with TCL specific questions from now...😉