Forum OpenACS Q&A: configure general-comments and administration

I set up OpenACS 5.2 and I'm having a problem of link spam on the blogger application, ie, people are using the comments feature to put irrelevant links on the site back to their site for the purpose of black hat search engine optimization.

On an older version of OpenACS on another site, I had to mount general-comments, it appeared in the site map and I could go to the /general-comments/admin/ to delete comments, ect.

On this version, it appears that general-comments is an unmounted application. I've spent an hour looking over the forums and surfing around the acs-admin, etc, trying to find out where to configure or administrate general-comments. It's not at all intuitive. The only things I've been able to find are a place to delete general-comments and it's in the package manager.

I'd like to remove the recent link spam and turn off general comments for users who are not logged in.

What am I missing?

Posted by Dave Bauer on

Try to post a comment and note the URL to see where general-comments is mounted.

Also check the lars-blogger admin page and see if "trackback" is enabled. Trackback was a feature to allow comments to be posted to your site by a web api. It doesn't require authentication, so it is easy to post spam comments that way.

Posted by Eric Wolfram on
Hi, thanks for the clue dave. I'm still unable to administer the comments in the blog. It appears to be calling comment-add from the blog instance, ie,


Although, when I click on add comments, I expect to get a form, but I get this error:


We are sorry. The URL /comment-add is in unrecognized format.

So I don't know how the link-spammers are getting around this bug. general-comments is not mounted in /blogger/.

Does this look like the the trackback feature? When I turn off trackback, nothing happens. How do I delete or administer this feature?

The three things I'm able to configure:

[i] Enable auto-discovery and sending of trackback pings
[i] Enable incoming trackback

I set them all to 0 and the comments feature still seams turned on. I set NumberOfCommentsInIncludelet to 0 and the comments are still there, beneeth each blog entry and in the sidebar navigation.

Am I missing something in the admin or am I going to have to go to /packages/blogger with emacs and start ripping out pieces of code :-P

FYI, here's the blog:


Posted by Dave Bauer on
Weird, I don't know about general-comments, look like it is not installed correctly. If you turn off trackback nothing will "happen" it just won't enable the feature. There isn't any visible user interface to trackback, its an automatic comment sent from another web site.


Posted by Ben Koot on
General comments module seems to have a parameter... (AutoApproveComments {i} Sets wether comments go live immedeatly. Values are Y and f.) replacing the old interface. To bad because that function gave a perfect overview and a of possibly unwanted posted plus a revision option.

The current solution , if set to "f" should generate an email to a moderator (doesn't hapen), but more importantly flag the poster a message that the message is send in for review. (not available). Effectively this parameter seems pretty pointless. It would be great to have the old interface (5.1?) back.



Posted by Eric Wolfram on
The issue is resolved. Indeed Dave was right and there was something wrong with the way the system was installed.

This was strange. general-comments was appearing as an "unmounted singleton" and not in the site map. It was also not appearing in the pulldown where you mount applications on the site-map. I know I never mounted it because the site in question had no need. A real puzzle.

After posting this yesterday, had a HD failure and when they restored, the unwanted link-spam was still there, however, general-comments wasn't in the "unmounted singleton" area but it was appearing in the pulldown.

I was able to mount the application and configure it to require approval, as I would have expected, and then go to /general-comments/ and reject all the link spam.

At this point, I'm unsure what fixed the issue. Probably the reboot. Maybe it was the restore.