Forum .LRN Q&A: Re: Assessment package

5: Re: Assessment package (response to 3)
Posted by Rocael Hernández Rizzardini on
The best guides I found are:

upgrades is a matter of trying multiple times until you have all the process working smoothly, we just upgraded to 5.2.3, from 5.1.x, about 2 years of not major upgrades, it took us a few weeks to have the process running fine since we have plenty of customizations.

If you are using CVS, you import the new code, merge, resolve conflicts and test upgrade from /apm.

6: Re: Assessment package (response to 5)
Posted by Matthew Coupe on
I downloaded the latest release, 5.2.3 from the download page at

When I come to upgrade from local it is telling me that these packages are 5.2.3b2. Is that the latest version or should I check out 5.2.3 from CVS instead of using the one on the download page?

Also, which is the latest stable version of dotLRN comptabile with 5.2.3? I'll need to check that out of CVS right, dotLRN-all or something like that.

7: Re: Assessment package (response to 6)
Posted by Rocael Hernández Rizzardini on
Use the latest stable .LRN 2.2.0final:
Should be oacs 5.2.3.
8: Re: Assessment package (response to 7)
Posted by Matthew Coupe on

I am in the process of upgrading this now however I keep getting the same error message when testing out some of the functionality. I think it may have something to do with xotcl. I am having trouble installing xotcl on my server, is this a requirement to get all of the packages in dotLRN 2.20 and OpenACS 5.2.3 to work? The errors I'm getting all seem to be pretty similar and I believe are syntactical.

bad variable name "af_to_sql(add_class_instance__active_start_date)": upvar won't create a scalar variable that looks like an array element
while executing
"global $name"
("to_sql" arm line 10)
invoked from within
"switch $flag {

key {
if { [info exists af_key_name($form_name)] } {
return -c..."
(procedure "ad_form" line 261)
invoked from within
"ad_form -name add_class_instance -form {


9: Re: Assessment package (response to 8)
Posted by Gustaf Neumann on
I don't know where the error comes from, but i know, i does not come from xotcl.

What troubles do you have installing xotcl?

10: Re: Assessment package (response to 9)
Posted by Matthew Coupe on
Hi Gustaf,

I've installed xotcl 1.5.2 on the server, configured and make-aol'd it.

I've upgraded everything to OpenACS 5.2.3 and dotLRN 2.2.0 except XOTCL which I haven't been able to install. I get the error message I reported earlier when I try and do things such as add a new class, create an assessment etc.

Errors I get with XOTCL include

[-conn:upgrade::1] Error: during '::xotcl::Object instproc'
during '::xotcl::Object instproc'
::xotcl::Object ::xotcl::Object->configure
invoked from within
"::xotcl::Object configure \
-instproc contains {{-withnew:boolean true} -object {-class ::xotcl::Object} cmds} {
if {![info exists object]} {set obje..."

On boot up....

Error: Error sourcing /var/lib/aolserver/upgrade/packages/xotcl-core/tcl/generic-procs.tcl:
during '::Generic::CrClass ad_doc'
::Generic::CrClass ::xotcl::Object->configure
::xotcl::Class ::xotcl::Class->recreate
::xotcl::Class ::xotcl::Class->create
::xotcl::Class ::xotcl::Class->unknown
invoked from within
"Class CrClass -superclass Class -parameter {
{supertype content_revision}
(in namespace eval "::Generic" script line 3)
invoked from within
"namespace eval ::Generic {

Class CrClass -superclass Class -parameter {
{supertype content_revision}
(file "/var/lib/aolserver/upgrade/packages/xotcl-core/tcl/generic-procs.tcl" line 9)
invoked from within

Error: Error sourcing /var/lib/aolserver/upgrade/packages/xml-rpc/tcl/test/xml-rpc-test-procs.tcl:
::ad_proc: unable to dispatch method '-private'
while executing
"ad_proc -private _${package_key}__$testcase_id {} "
# make sure errorlevel gets through. this is not 100% cleaned up.
global error..."
(procedure "aa_register_case" line 104)
invoked from within
"aa_register_case -cats script xml_rpc_mounted {
Test to make sure the xml-rpc package has been mounted
} {
aa_run_with_teardown -rollback -tes..."
(file "/var/lib/aolserver/upgrade/packages/xml-rpc/tcl/test/xml-rpc-test-procs.tcl" line 9)
invoked from within
"source $__file "

11: Re: Assessment package (response to 9)
Posted by Matthew Coupe on
Once I'm booted up I'm now getting

invalid command name "auth::require_login"
while executing
(procedure "ad_maybe_redirect_for_registration" line 2)
invoked from within
invoked from within
"set user_id [ad_maybe_redirect_for_registration]"
("uplevel" body line 40)
invoked from within
"uplevel {

12: Re: Assessment package (response to 11)
Posted by Roel Canicula on
I encountered the same problems when I upgraded to Fedora Core 6.

I tried different combinations of AOLServer 4.0.10, 4.5.x, from CVS and tcl <= 8.4.6, 8.4.13, .14, CVS but never got xowiki working and got intermittent server crashes.

Here's how I solved it:

- Downgraded bash (FC6 comes with bash-3.1, I downloaded the bash-3.0.x source, compiled it, symlinked /bin/sh to the compiled bash binary)

- Used tcl-8.4.6 instead of tcl-8.4.13 that comes with FC6 (it's unfortunate coz the tcl in FC6 already has threads enabled)

Now everything works perfectly with aolserver-4.0.10, xotcl-1.5.2 and the latest xowiki and xotcl-core from HEAD.