Forum OpenACS Q&A: getting old versions of openacs working, versus getting the latest version working

Request notifications

Hi,

I got the database dumps and file tarballs of a couple old sites I was running, and the old sites work with naviserv-4.99.5. However, a new install of openacs-5.9.1 does not. I can attach any info you need/ask for to this message, it looks like it can't see some tcl commands, like acs::group_something.

I tried to build navi-4.99.17, but got stuck (more details here: https://openacs.org/forums/message-view?message_id=5403781 ), because I thought I would test the new install using the newer naviserv to see if it needed that.

-Jim

Update: I succeeded building the new naviserver: since the nsssl module was included in the naviserv tarball, I had to address the whole ssl/tls thing. I run debian stretch, and installing libssl-dev was the build dependency that allowed the build of naviserver to run to completion.

Now, I have encountered a new problem, which is that I get an error when having openacs core load its initial data model, that I believe can be summarized as:

invalid command name "::try"
while executing
"::try {
set package_uri $version(package.url)
set package_type $version(package.type)
set package_name $version(package-name)
..."

and, I also have the complete build log, which is here: http://termbin.com/w5c0

Please take a look, and thanks in advance.

-Jim

What i can see:
- "try" is a builtin of Tcl 8.6 and supported scripted via tcllib. tcllib in version 1.19 is recommended (see [1]).
- Tcl 8.5.13 is 8 years old. In general, tcl 8.6.* is recommended. If you really want to go for Tcl 8.5, use Tcl 8.5.18 (this can be configured in [1])
The "try" problem might be the consequence of an outdated tcllib and/or an outdated version of Tcl.

Furthermore, the system lacks xotcl (the CVS HEAD version requires at least 2.0, 2.2 is recommended, since several years, XOTcl is part of nsf). Get it from [2] or via [1].

[1] https://openacs.org/xowiki/naviserver-openacs
[2] https://next-scripting.org

Gustaf,

Thanks for your reply... After making that log of the attempted install, I went ahead and grabbed xotcl-1.6.8, installed that, and ran the install again (i.e., drop the db, create a new blank db, then run the web server) and got very similar results. Rather than detailing that, I'll get the new tcl-8.6 and the new tcllib, and rebuild the whole stack.

I'll post here whether I succeed or fail.

-Jim

Don't waste your time with xotcl-1.6.8, this won't work with tcl 8.6 and newer OpenACS versions: already OpenACS 5.9.0 requires XOTcl 2.0 [1]. Get instead nsf 2.2.0 instead as indicated above...

[1] https://openacs.org/xowiki/openacs-compatibility-matrix

Hi again all, Gustaf...

I'm trying to build a thread module for tcl, but I can't configure it, because it needs tclconfigure, which I try to get, but the server keeps throwing an error... well, take a look at this:

build@jlynch:/usr/src/openacs-stack$ fossil clone https://core.tcl-lang.org/tclconfig ~/repos/tcl_tclconfig/tclconfig.fossil
Round-trips: 1 Artifacts sent: 0 received: 0
malformed cfile line
Round-trips: 2 Artifacts sent: 0 received: 1248
malformed cfile line
Round-trips: 2 Artifacts sent: 0 received: 1249
Clone done, sent: 608 received: 740574 ip: 2.0.1.187
server returned an error - clone aborted

Do I have the right clone URL? Any other problems you can see here? Thanks,

-Jim

All this "wisdom" is in install-ns. The easiest is to get libthread from sourceforge [1] and don't forget to configure --with-naviserver [2] .

[1] https://github.com/gustafn/install-ns/blob/master/install-ns.sh#L432
[2] https://github.com/gustafn/install-ns/blob/master/install-ns.sh#L554

OK, seems that problem has been solved... I loaded the data model and was also able to view the new site without error. Now I'm going to put the site on port 80 (I was using 2000 so I could start it without going to root login).

Thanks all! (And, I'll be back, no doubt)

-Jim