Forum OpenACS Q&A: Installing Oracle without X server

Request notifications

Collapse
Posted by Jarkko Laine on
I'm setting up a test environment for OACS/dotLRN on a server running Red Hat 7.3. I was following the Oracle installation document when I noticed that installing Oracle needs an X server. Is this really true, i.e. can't I install Oracle using ssh? The problem is that the server is in Finland and I'm in Switzerland, so it's not possible for me to get by the server and do console login.

I guess it would be possible to accomplish the x client stuff through ssh with my Apple PowerBook (OS X 10.2) but I've never used an X client with it so any advice on how this problem could be solved would be highly appreciated.

TIA,
Jarkko

Collapse
Posted by Malte Sussdorff on
You might want to install VNC on the server and connect this way. http://www.uk.research.att.com/vnc/
Collapse
Posted by Janine Ohmer on
Pretty lame, isn't it?

A few versions ago (probably 8.1.5 or 8.1.6) I tried to get around this.  Oracle's install docs mentioned an environment variable you can set to have the install print *absolutely nothing*, taking all it's answers from a text file.  This ought to work in all cases.  Unfortunately, the installer still checked for the presence of an X server, even though it wasn't going to make use of it, and would stop if one wasn't found.  I'll be very surprised if this has been fixed, but you might want to look at the official install docs and see if it's still documented.

Malte's right, VNC is the best way to do this.  At least you are running Redhat 7.3 so you should alread have the X server installed.  Until recently Redhat didn't include X in a server install because you don't need or want it on a server.  Unless you're installing Oracle!

Collapse
Posted by Jarkko Laine on
Thanks for the tips!

I got both vncserver on the server and VNCThing on my PBook up and and running and even the ssh tunneling working.

X Windows seems to work ok (tested with emacs and gimp), but when I run runInstaller from the console, the process just says:

[oracle@swissnet Disk1]$ Initializing Java Virtual Machine from ../stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/bin/jre. Please wait...

After 20 minutes I'm getting a bit tired of waiting...

Collapse
Posted by Janine Ohmer on
I think that means you need to have the environment variable LD_ASSUME_KERNEL set to 2.2.5.

If you search here, there have been a few threads about this recently.

Collapse
Posted by C. R. Oldham on
Are you sure your DISPLAY variable is set correctly?
Collapse
Posted by Tilmann Singer on
When using X over ssh there is also the danger of a broken ssh connection. I guess when you loose the connection you have to start the installation over, unless you have something like the 'screen' program that also allows to re-attach to forwarded X programs as well. So VNC is propably the best.
Collapse
Posted by Jarkko Laine on
Janine, thanks, I got a bit further.

C.R., I'm not quite sure. When I set DISPLAY to localhost:0.0, no x windows apps are starting. When I change 0.0 to 1.0, they all work well. However, the problem below is the same with both of them.

So, I'm not quit there yet. This time the runInstaller script gets a bit further, and probably starts ok, because the last thing I can see is:

Object Monitor Status
---------------------
OK
However, no installer window is launched, the script just sits there.

Collapse
Posted by Malte Sussdorff on
You might have to do "unset lang" if your language setting contains the "@" sign, as java crashes in this case.
Collapse
Posted by Janine Ohmer on
If you're using VNC you don't need to set the DISPLAY variable - it's all done for you.  Basically, if you see the X desktop,  you've got it set correctly.

I haven't seen this problem before so hopefully it is something like what Malte suggested.

Collapse
Posted by Jarkko Laine on
Malte,

My language settings contained @ so I unset it:

[oracle@swissnet oracle]$ echo $LANG
fi_FI@euro
[oracle@swissnet oracle]$ unset LANG
[oracle@swissnet oracle]$ echo $LANG

[oracle@swissnet oracle]$ 
It didn't change the behaviour of the install script, though.

Collapse
Posted by Malte Sussdorff on
I added a detailed description in the general comments for installing Oracle 8.1.7. But it seems to be lost....

Anyway, for RH 7.3 you need to keep three things in mind:

- Install compat libraries
- LD_ASSUME_KERNEL=2.2.5
- unset LANG

Have a look at http://seneca.omniscia.org/~vivake/log/archives/000041.html, this should help as well.

Collapse
Posted by Janine Ohmer on
You can use Oracle's glibc patch instead of the compat libraries - it has always worked for me and is easier.  Tom Jackson was verifying this, not sure how far he got.  There's a thread about it here somewhere.
Collapse
Posted by Jon Griffin on
Sorry I am late, but you in other timezones are awake even before my baby ;).

If you have another installation you can zip up the appropriate dirs and unzip on the new machine.

I have done this many times remotely and I have a tarball (but it is huge). Note, you need the files before you create the db's. This works well, and you don't need to worry about vnc or other unreliable things breaking in the middle. Contact me off list if you would like a copy (but it would be easier if you can find one closer).

Collapse
Posted by Rocael Hernández Rizzardini on
I had the same problem, my server is at US and I'm in Guatemala, I've installed all the rpms required for X and then followed the info that Jun give here: http://ccm.redhat.com/bboard-archive/webdb/000J3d.html

first try to open something like an xterm or emacs or netscape in from your remote server in your local machine, in that way you can see that X through SSH works.

Collapse
Posted by Tom Jackson on

Janinie,

Yes I am verifying if you need the compat libs for Oracle 8.1.7 on Redhad 8.0. I don't know if this applies to 7.3 or not.

I have passed the acceptance.sql test, but I will install OpenACS today, fingers crossed. I'll post my results on the thread dealing with this issue. For now all I have done is to set LD_ASSUME_KERNEL=2.2.5 in every environment using oracle, and I installed the glibc stub patch, which is available with the 8.1.7 download.

Collapse
Posted by Janine Ohmer on
Jon, I've done that too and it does work.  I've always been very careful to make sure that the two systems were fairly identical, though - I don't know if it would work if the systems were more than a little bit different.  Even two Redhat systems at different levels of up2date might be suspect, though I don't know for sure.

Tom, I've done it on 7.3 so I'm pretty sure it will work.  I'm  still looking forward to your results, though.

Collapse
Posted by Jarkko Laine on
Janine,

I think you can't use Oracle's patch before you have run the installer, which, for me, seems not to get through...

Malte,

I followed the Bobo's log's instructions but it didn't get me any further :-(

Rocael,

I've tried this now both with VNC and ssh X forwarding and the result is the same. Other X programs seem to work fine either way.

Collapse
Posted by Rocael Hernández Rizzardini on
That means that you get for example an xterm working (graphically) in your OS X box? This means that it opens an new window in your local graphic X system and you can move it, etc.
if yes, I will suggest you to read Bruno's instruction on installing oracle in redhat 7.x, it needs a special configuration to get it working, check it here http://archive.greenpeace.org/~bruno/oracle.html .

if not, your are not still tunneling X through ssh.

Collapse
Posted by Jarkko Laine on
Rocael,

Yes, I can get e.g. Gimp and Xemacs running on my OS X on both XDarwin and VNC.

I think Bruno's instructions are pretty close to those Malte's link above points to, but I'll make a new try from scratch with them, however.

Collapse
Posted by Ola Hansson on
Hi Jarko,

I had the same problem as you do but on Debian 3.0 once upon a time, and I gave up then. However I just tried again to install Oracle 8.1.7 remotely over ssh (openssh) and it works! (Well I have managed to display the Oracle Universal Installer) ... If the installation will complete entirely remains to be seen.

Before, I logged in to my remote server with "ssh -X mailto:nsadmin@myserver.com";, i.e., as user nsadmin. I then did the initial steps from there, su:ing to oracle etc. When I tried to run runInstaller from there it failed to work (DISPLAY not set, or whatever).

But this time I logged out of the remote session altogether when it was time to run runInstaller and logged in again, this time as user oracle; "ssh -X mailto:oracle@myserver.com";. That way it "just worked".

Of course, I am on Debian but it might work on OS X too..

Try to use ssh or openssh with the -X (capital X) flag if you have it on your platform.

Good luck,

Collapse
Posted by Ola Hansson on
Doh! Your name is Jarkko. Sorry.
<IIRC>
When you have logged in to the remote host I think you should not set DISPLAY manually - ssh and the "-X" will do that for you. If you set it incorrectly it may very well seem to work but the tunnel will be by-passed IIRC. So you might end up sending passwords in the clear.
</IIRC>
Collapse
Posted by Jarkko Laine on
Ola,

Thanks, but it didn't help either. runInstaller doesn't give any error, it just stucks after saying that "Object Monitor Status is OK"

I have to try to find a PC with x server from school, so I can test if this is because of my computer.

Collapse
Posted by Jarkko Laine on
OK, I tried to accomplish the task with a WIN2000 workstation, with same results, so I think the problem isn't in this end.

Still trying...

Collapse
Posted by Jarkko Laine on
I tried to do the installation from scratch according to Bruno's instructions, but the end result is the same :-(

Now I'm really running out of options...

Collapse
Posted by jerry arns on
I installed vncserver and it works great !

I could install Oracle8.1.7 for Linux (RedHat6.2) from a far away Windows2000 box through SSH tunneling through internet with no problem at all.

I'm glad I read this post !

Thx

Collapse
Posted by Jarkko Laine on
I got an Oracle tarball from Peter and after some small tweaking got it to work, or at least I'd think so. Creation of ora8 database at least went finally ok.

Other thing is that after a reboot all the PostgreSQL data seems to have disappeared, but that's another story and thread topic...