Forum OpenACS Development: Who maintains photo-album, package owners in general

Trying to figure out who maintains the photo-album package I found those two pages:

The second one carries a note "(Last updated on August 29th, 2002 by Janine Sisk)", and has partially different owners listed than the first, more recent one. May I suggest to merge these two pages to avoid having contradicting information on our website?

And the original question was - who maintains photo-album? The older list says Ivan Histand, to whom I sent two mails (the first one bounced), but without a reply for about a week. I have some improvements that I would like to get in, but not without coordination with someone who feels responsible for that package.

Posted by tammy m on
I don't know but there is a link to an updated version with some much needed functionality (compressed uploads for speed on modems and multiple file uploads) that is mentioned in this post. It's located at this url and it would be great if that if could be gotten into CVS someday too;)
Posted by Jarkko Laine on

It's Jeff Davis who's the maintainer and he's got a much improved version of the package, too (in His version is now even ported to oracle so I think it should be ready for at least contrib repository. Please do not put improvements in the version in oacs cvs, since I'd say it's more or less deprecated by now.

Posted by Jade Rubick on
Grr, this is the first I've heard of photo-album being deprecated.

This is another example of a no-upgrade path to a package.

Do we always have to do this?

Yes, I could write the upgrade scripts myself, and I guess I would rather have Jeff release his code than keep it for himself.

I just find it frustrating when perfectly good packages are left hanging because someone improves it without thinking about upgrades.

Posted by Jarkko Laine on

Sorry about my bad English. Photo album is of course not deprecated. What I meant was that IMHO one shouldn't use the version in the CVS at the moment since Jeff's version is so much improved (and yes, it has upgrade scripts now). We should have it in CVS soon (don't say you've heard this before, I know :)

Sorry for all the hassle.

Posted by Dave Bauer on

photo-album is not deprecated. There is no reason upgrade scripts can't be produced. Jeff fixed it for his own uses, but did not have time to finish it for contribution back to the toolkit. Some other people liked his changes so they wanted to help to get those improvements into OpenACS.

Upgrade scripts *have* been written. Twice! Once by me and once by Vinod.

The enhanced package has been ready to go into CVS (at least into contrib) for a while. Let's get it in there.

Posted by Vinod Kurup on

Could you send me your APM? I have my APM up at I'll diff our versions and then try to commit it this week.

I'll plan to commit it to the 4.6 branch, unless someone informs me otherwise before then.

Posted by Vinod Kurup on
I integrated Michael's and my changes into CVS. It's currently in contrib on the HEAD. This includes porting Jeff's changes to Oracle, upgrade scripts for PG and Oracle, and working drop scripts. I bumped the version number to 4.5.

This version requires ImageMagick and jhead to be installed on your system.

Okay, so we have photo-album, photo-album-lite, Jeff's version, and Vinod's version.  What would it take in terms of testing and development to get the best code (apparently Vinod's compilation of peoples' work) back in as the core photo-album module?  Or is that what you already did?

What is jhead used for?  Looking at the docs, it's for digital camera images.  If you don't use a digital camera, can you use the new photo-album without installing jhead?

Posted by Jeff Davis on
photo-album-lite and photo-album should both just go away and the contrib photo album should be the only version (and I guess it should go back in to packages although I sort of like things which are not really critical packages to be in contrib and more clearly independent modules rather than part of openacs proper -- it's a small step in the direction of non monolithic releases).

jhead pulls out the exif data and photo-album as written won't work without it. It's also used to remove the embeded thumbnail from the thumbnailed image, some cameras (and I imagine things like photoshop) produce embeded thumbnails which can be quite large and when imagemagick scales the image for a thumbnail it does not remove the embeded thumbnail which means the image file can be 40k rather than 8k. Anyway, it's public domain and pretty easy to install so I am disinclined to change anything so it works without it. If someone else wants to that's fine I guess.

Vinod applied the patches to the version in contrib/packages so there are not two versions floating around.

I have a bunch of small fixes to photo-album that I would like to check into /contrib/packages/photo-album on the HEAD.  Here's the summary:

* tcl/photo-album-procs.tcl:
    - in pa_context_bar_list, instead of returning nothing when we are in the root folder, should return [list $final].  Otherwise, you get an incomplete context bar in the root folder.

* www/clipboards.adp
* www/clipboard-delete.tcl (NEW)
    - changes to allow users to delete a photo clipboard (capability exists in SQL API but never exposed in UI)

* www/photo-move-oracle.xql
* www/photo-move-postgresql.xql
* www/photo-move.tcl
    - change to allow users to move photos into any album below the root folder where they have appropriate permissions (to be more consistent with album-move)

* context bar fix to 16 ADP files
    - The context bar is being passed to the master template as "context_list".  Changed to "context" so that it works with the current default-master.tcl and is more consistent with other packages.

Can I have permission to check these changes in?  Or, if you prefer, I can email a tarball of the affected files.  If so, who should I send them to?


Posted by Jeff Davis on
Robert, I gave you commit on contrib/packages/photo-album.
Feel free to commit your changes.
You rock!  Ok, I checked the files in.

Could you do me a favor and quickly eyeball my change in www/photo-move-oracle.xql?  I think it's correct, but I don't have an Oracle installation to test against.

Also, who/when can we move photo-album into packages from contrib?


Posted by Tilmann Singer on
The original package list from Janine Sisk is still online:

Peter, didn't you want to remove this? Is 'Package Inventory' (at now the recommended way to find out who maintains what?

Posted by Carl Robert Blesius on
Why not just generate a package inventory list for the maintainer page from the data in bug tracker and the APM?

1. We add a new "component maintainer" using the bug tracker admin interface we automatically update the page and this person is automatically assigned new bugs for that package.
2. If we want the page's description of package functionality improved we add it to the text in the APM and the description for administrators in the APM is improved.
3. Most importantly: nobody has to mess with that page again.

Hack so we do not loose any info that is on the page now:
We add quality/test status as well as major todo's/plans to the description in the bug tracker (not sure if this is needed though... might be better to just link to a filtered list of high priority and/or critical bugs for that package).

thanks for finding the package owners page. I'll replace it with a link to the package inventory page as well as try to update the package inventory page to reflect the current state of affairs.

I recently removed some packages from core and one or two maintainers can probably be moved over from Janine's doc. Also, I'd like to start moving some packages into an obsolete cvs directory, for example the superseeded photo album apps.

Posted by Chris Johnson on
I have cvs up'd my contrib/packages/photo-album and placed that in my project's packages/photo-album dir, installed the package (gone through this twice now dropping the whole db to make sure), but then I can't create a new album. Could this error be because I'm running postgres 7.3.2 ? Is this a bug?
[16/Jun/2003:01:41:41][8505.49156][-conn:relentless-oacs::0] Debug: PLPGSQL: bypassed anon function
[16/Jun/2003:01:41:41][8505.49156][-conn:relentless-oacs::0] Notice: Querying '
      select pa_album__new (
	      'test1', -- name          
	      '344', -- album_id       
	      '343', -- parent_id	     
      	      't', -- is_live	     
	      '298', -- creation_user  
	      '', -- creation_ip    
	      'test1', -- title	     
	      'test desc', -- description    
	      'test story', -- story	    
              'chris', -- photographer
	      null, -- revision_id
	      current_timestamp, -- creation_date
	      null, -- locale
	      null, -- context_id
	      current_timestamp, -- publish_date
	      null -- nls_language
[16/Jun/2003:01:41:41][8505.49156][-conn:relentless-oacs::0] Error: Ns_PgExec: result status: 7 message: ERROR:  
Function pa_album__new("unknown", "unknown", 
"unknown", "unknown", "unknown", "unknown", "unknown", "unknown", "unknown", "unknown", "unknown", 
timestamptz, "unknown", "unknown", timestamptz, "unknown") does not exist
	Unable to identify a function that satisfies the given argument types
	You may need to add explicit typecasts
Posted by Vinod Kurup on
Hi Chris,

Yes, i think this is a PG7.3 issue. I did my testing on 7.2. We need to change 'timestamp' to 'timestamptz' in all of the PL/pgSQL function definitions.

Posted by Dave Bauer on

Yes this is due to 7.3.x

I fixed it in CVS, bumped the version number and created an upgrade sql file.

I'm now seeing this error when trying to add a regular old jpeg. This is Jeff's original package running on 7.3.2:
ERROR:  Function datetime("unknown") does not exist
	Unable to identify a function that satisfies the given argument types
	You may need to add explicit typecasts
                    UPDATE pa_photos 
                    SET camera_model = NULL,
                    user_filename = 'test.jpg',
                    date_taken = datetime(NULL),
                    flash = '0',
                    aperture = NULL,
                    metering = NULL,
                    focal_length = NULL,
                    exposure_time = NULL,
                    focus_distance = NULL,
                    sha256 = 'd7a0df414fc5dec295b20a15639f0fa1436f9a1087ef6941c565e871d87a744b'
                    WHERE pa_photo_id = '5443'

Looks like datetime has changed (or was possibly removed) in 7.3.2. Is anyone familiar with the change?
I got the
P sql/postgresql/pl-pgsql.sql
U sql/postgresql/upgrade/upgrade-4.5-4.6.sql

but I don't see that has changed... just fyi after updating.

Thanks for your solve, will test upgrade shortly.

I was about to complain about my upgrade failing... but I tried it once more (it may fail from the gui only??) manually running the upgrade script, and voila! I can create an album! Yay!!

Thx Dave!