Forum OpenACS Development: LORS, Evaluation, Assessment, User-Tracking update

Hello to all,
just an update on these packages and where is happenning the development:

1. LORS stable is at oacs-5-1, the new LORS and the lors-central package is been worked at oacs-5-2, it already has upgrade scripts from the 5-1 version and the aim is to make it stable for production use in the next days. Bug-fixes and new development will go into oacs-5-2. **

2. Evaluation, is stable in oacs-5-1 & oacs-5-2, the main difference is that oacs-5-2 now uses the TCL CR API, the upgrade should be easy from 5-1 to 5-2. Further development will happen at oacs-5-2. **

3. Assessment has an stable release in oacs-5-2, the bug fixes & small enhancements will go into oacs-5-2.

4. User-tracking, will continue its development fron now on oacs-5-2 branch.

** There won't be a merge between the 2 branches (many differences), so if you want something in both, commit in both.

Collapse
Posted by Nima Mazloumi on
Hey Rocael,

can you kindly give a brief overview on the current status of lors, lorsm...I would like to install everything fresh and need to know what is the most accurate: head, oacs-5-1, oacs-5-2.

Thanks,
Nima

Collapse
Posted by Nima Mazloumi on
Also something what I don't understand is what all is required to get a working installation?

Lors-central 0.1a4 from oacs-5-2 requires:

Learning Object Repository Service 0.6d4
Clipboard 0.1d
LORS Management 0.7d

But then the portlet stuff is missing:

dotLRN LORS Management Applet 0.4d

Shall I install that as well?

What is recommended HEAD, oacs-5-1, oacs-5-2 or does this depend on the package?

Nima,

Take the one from oacs-5-2, it is on beta yet. If you are thinking for production, please test it and report bugs before installing in your prod server. Probably Galileo will start to use it on production in a couple of weeks. Mostly a UI review is needed.

Yes, download all the lors-central dependencies.

Info about this new LORS:
http://openacs.org/news/item?item_id=292716

Collapse
Posted by Mark Aufflick on
Hi Rocael,

I am trying to get the user-tracking package to work and could use a little help.

I have installed the user-tracking package from cvs (5-1 branch as it is a .lrn installation - I will also try the 5-2 branch).

I have also installed the extendedheaders config as per http://openacs.org/forums/message-view?message_id=291877

I have also installed the Time::Local perl module required by the awstats perl script (and verified that it can run).

My server access log is showing the user id and the community id as expected.

When I click on any of the generate stats links or wait for the scheduled proc to run, I see the script getting run in the error.log, but I never see any of the resulting .dat or awstats/* files that the code indicates should be created.

Hence, I always see "no data for this month".

Can you give me some pointers about how to get it up and running?

Cheers,

Mark.

Hi Mark,

I think the right version of user-tracking is currently in the 5-2 branch, but it's possible that the scheduled proc doesn't work properly due to recent changes we introduced in the awstats logic. Anyway it should run when you click in the generate stats link.

Can you verify if the file tools/logresolvemerge.pl got execution permission?

Are lines written in error.log similar to the following?

[06/jul/2005:16:43:09][12512.57352][-conn:elane::4] Notice: Update for config ".../packages/user-tracking/www/awstats/cgi-bin/../../../config/awstats_dotlrn.site.conf"
With data in log file ".../packages/user-tracking/tools/logresolvemerge.pl .../logs/elane.log.2005-07-0[2-9]* .../logs/elane.log.2005-07-1[0-9]* .../logs/elane.log.2005-07-2[0-9]* .../logs/elane.log.2005-07-3[0-1]* .../logs/elane.log.2005-08-01* .../logs/elane.log |"...
Phase 1 : First bypass old records, searching new record...
Searching new records from beginning of log file...
Phase 2 : Now process new records (Flush history on disk after 20000 hosts)...
Jumped lines in file: 0
Parsed lines in file: 714
Found 0 dropped records,
Found 579 corrupted records,
Found 0 old records,
Found 135 new qualified records.

Collapse
Posted by Mark Aufflick on
I changed over to the 5-2 branch and the logresolvemerge.pl script wasn't executable.

CVS is such a pain - if you do your FIRST checkin of a file with execute bit, it will checkout with the execute bit. Otherwose you're doomed. Maybe it can be fixed right on the repository, but I'm not in favour of direct cvs repository manipulation ;)

So I fixed that and then discovered that there were harde coded references to elane in the logfile names in loading.tcl and loading2.tcl

If you like I can change that over to use the variables from the nsd config file but you may prefer to do that yourself - let me know.

Also, while it feels a bit nasty, the post-install apm callback could do a chmod on logresolvemerge.pl to make it executable.

You are right. We forgot to delete these hardcode references before committing recent changes to CVS. In fact, all references to ${logdir}elane.log in these files should be replaced by $logs whose value is got at the beginning of the files.
Of course, you can change it. If not, I’ll fix that bug tomorrow in the morning.

About doing logrelsolvemerge.pl executable, I am not sure but I think Rocael tried to solve the problem manipulating directly the repository. I like your “chmod” solution.

Thanks for the feedback!

Collapse
Posted by Mark Aufflick on
Also I must say two things:

a) the stats are fantastic - this is a really valuable addition.

b) there are some fairly horrible security issues to do with the way file names are passed in via the GET string

I am hunting down a bug in the visits by user - if I can't get anywhere with it i'll post a bug.

Collapse
Posted by Mark Aufflick on
I also pity you trying to modify awstats - surely the nastiest piece of Perl I have read - and I code with 60,000 line OO perl systems every day!
Collapse
Posted by Mark Aufflick on
sorry for the multi-post. I post to forums like i leave voicemail messages...

Not sure if this is to do with my site config, but there is an extra piece of junk info (some floating point number) before the quoted user id.

I just had to change the LogFormat config value to:

LogFormat= "%host %other %other %time1 %methodurl %code %bytesd %refererquot %uaquot %other %lognamequot %extra1

Hello,

I've tried to install evaluation on oracle. I've got dotlrn from oacs-5-1 branch and the evaluation package is a checkout from oacs-5-2 branch on june, 14.

Oracle complains on creating the "comment" attribute for evaluation_answers content type. "comment" is a reserved word in Oracle.

I'm not sure of how much work it's needed to fix this. Can anyone give me a guess so I evaluate if we can do it or not. We want to use this package at uned.

Thanks,

Hi Emmanuelle,

Fixed. Please update the code and try again. That happened because a couple of months ago some upgrades were made to the package, but it was not tested well, so if you find any other bug don't hesitate to tell me (contact me by email if you want).

Regards,

Jose Pablo

Hi Jose Pablo:

So quickly?! I was afraid that datamodel rewrite was needed. I'm going to check it out and retest. Thanks you.