Forum OpenACS Q&A: OpenACS is not working.

Collapse
Posted by Mattia Righetti on
I installed OpenACS on a fresh installation of Ubuntu 13.10, with command apt-get install openacs and then I configured it with PostgreSQL 9.2.
That's my error.log... Who can help me understanding where is the problem?
TIA

[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Notice: nsmain: AOLserver/4.5.1 starting
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Notice: nsmain: security info: uid=33, euid=33, gid=33, egid=33
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Notice: nsmain: max files: FD_SETSIZE = 1024, rl_cur = 4096, rl_max = 4096
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Warning: nsmain: rl_max > FD_SETSIZE
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Error: pidfile: failed to open pid file '/var/run/aolserver4/openacs.pid': 'No such file or directory'
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Notice: encoding: loaded: utf-8
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Notice: fastpath[openacs]: mapped GET /
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Notice: fastpath[openacs]: mapped HEAD /
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Notice: fastpath[openacs]: mapped POST /
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Notice: adp[openacs]: mapped GET /*.adp
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Notice: adp[openacs]: mapped HEAD /*.adp
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Notice: adp[openacs]: mapped POST /*.adp
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Notice: modload: loading '/usr/lib/aolserver4/bin/nssock.so'
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Notice: modload: loading '/usr/lib/aolserver4/bin/nslog.so'
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Notice: nslog: opened '/usr/share/openacs/log/openacs.log'
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Notice: modload: loading '/usr/lib/aolserver4/bin/nssha1.so'
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Warning: modload: could not find Ns_ModuleInit in /usr/lib/aolserver4/bin/nssha1.so
[18/Jan/2014:20:46:44][4151.18446744073069590272][-main-] Fatal: modload: failed to load module '/usr/lib/aolserver4/bin/nssha1.so'
Collapse
Posted by Gustaf Neumann on
There are known problems with aolserver and its modules in various Ubuntu versions (see e.g. [1]). The bug was recently fixed [2] in debian, but i am not sure how long this will take until this is contained in Ubuntu versions. You might consider to use the install scripts for OpenACS + NaviServer, which works for various Ubuntu versions.

best regards
-gustaf neumann

[1] https://openacs.org/forums/message-view?message_id=4074230
[2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=709271
[3] https://openacs.org/xowiki/naviserver-openacs

Collapse
Posted by Jim Lynch on
another thing aside from how ubuntu builds aolserver that you might run into, is postgres-9.2 works with openacs-5.8... anything earlier, and you'll most likely run into problems with 9.2. Having said that, it looks a lot like 9.2 out-of-the-box (so to speak) has been tested to work very well with openacs-5.8; as far as I'm aware, that's been accomplished by Gustaf. In the past, you had to alter the configuration of postgres, in the postgresql.conf file, but no longer (as of openacs-5.8): looks like it now fits seamlessly. I've been running naviserv-4.99.5 for about 4 months now, works well with openacs and seems much faster than on aolserver.
Collapse
Posted by Mattia Righetti on
Looking at log files, I tried to repair where fatal errors occurred and it worked. Now the problem is another (I suppose). If I install packages from repository or from local, they work. But when I create a new one (from /acs-admin/apm for example) so I find the directory in packages (with inside sql, tcl and www subdirectories) then if I try to add this new application in the main page (/admin/applications/application-add) it returns this error: "We had a problem creating the application.".
In the log files seems all ok.
Perhaps with NaviServer I won't have this problem? Can I install NaviServer with apt-get?
Collapse
Posted by Mattia Righetti on
In my machine I can install only Ubuntu 12.04 or Ubuntu 13.10 for a certain reason. I find out that when I install OpenACS via apt-get install open acs command, it installs the 5.5.1 version of OpenACS. So I checked on the matrix compatibility table and it works with AOLserver 4.5 (that has been installed with the command above) and PostgreSQL 8.4.
I tried to install OpenACS 5.8 with PostgreSQL 9.2 and AOLserver 4.5 uploading it and then trying to configure AOLserver root on /usr/share/openacs/ (that is where I put it), but it did not work.
I'm just a beginner. I like OpenACS and developing software in it, but sometimes it's so difficult to install...
Collapse
Posted by Jim Lynch on
do the logs have any indication as to why it won't work?
Collapse
Posted by Mattia Righetti on
No, I've just tried to create a new package and then add it to the application in the main page. Logs are the same... I mean that they are not changed.
Collapse
Posted by Antonio Pisano on
Mattia, I've bumped my head a lot on openacs installed by Debian packages and really, it's not worth the effort. It's not that they don't work, they somehow do, but there is a lot of tweaking needed to have a properly configured instance, so that the main purpose of the package is nullified. Also, you are getting software like 5 years old now and sometimes this is noticeable.

As Gustaf suggested, try installation scripts found at
https://openacs.org/xowiki/naviserver-openacs

They assume Debian/Ubuntu as distro, so they should be perfectly suitable to your requirements, and they are also very easy to use.

For assistance you can ask here and I will gladly help you.

Ciao

Collapse
Posted by Antonio Pisano on
Regarding OpenAcs5.8 on Aolserver4.5, I would suggest you to don't go that way :-)

Go for the scripts we linked to you, they will automatically download, compile and configure Naviserver from sources and OpenAcs5.8 from sources. There won't be much to do beside waiting!

Collapse
Posted by Benjamin Brink on
Definitely use the install script; or manually install by reading and following the script process ;-)

Issues with installing OpenACS packages via an Ubuntu-based install may be due to the aolserver start-up script not setting a dependent environmental variable --or using a broken value.

My experience with installing OpenACS on Ubuntu 10, 11 and 12 suggests that the Ubuntu software installation process for OpenACS is fraught with issues largely introduced by Ubuntu/Debian packaging system and version conflicts with each Ubuntu release; If you get OpenACS to work in these conditions, you might run into some fairly esoteric errors.

The admin hurdles can be avoided by running the referenced installation script.

By installing from the script you'll have a reference standard that is more easily diagnosed;

Also any errors you post will be providing useful feedback for maintaining the installation script.

cheers,

Collapse
Posted by Mattia Righetti on
The problem is that with those scripts, OpenACS is installed in a strange way, perhaps because of NaviServer (that I've never used). For example it creates a user 'nsadmin' and the OpenACS directory is in /var/www/.
I always used to install OpenACS in Ubuntu 10.04 LTS (and I've never used to have big problems) but now I can install on my VPS only Ubuntu 12 or 13.
Collapse
Posted by Mattia Righetti on
Ok, I've just tried to install OpenACS from scripts and I got this error:
------------------------ Installing Naviserver ---------------------------
install-ns.sh: line 288: cd: naviserver: No such file or directory

:(
Collapse
Posted by Gustaf Neumann on
I've recently updated the scripts to allow in addition to the installs from released version as well installations directly from the source code repositories (either git or mercurial; not activated by default).

It seems, i've not tested the non-HEAD version. Please refetch, unless i've made some typos, it should work now.

Sorry for the inconveniance